bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

"Whats New" - Tab keeps appearing after reboot using shared profile



Toolbars and Tabs
9 years ago
9 years ago


(Reporter: Florian, Unassigned)


Firefox Tracking Flags

(Not tracked)




9 years ago
User-Agent:       Opera/9.64 (Macintosh; Intel Mac OS X; U; de) Presto/2.1.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv: Gecko/20090715 Thunderbird/3.0b3

After a reboot the whats new tab keeps appearing even if it was closed during the last session.

Reproducible: Always

Steps to Reproduce:
2.Start Thunderbid

Actual Results:  
Whats New Tab appears.

Expected Results:  
Whats New Tab should not appear.

I know it is not a major bug but it is very disturbing for me.
If you use about config (http://kb.mozillazine.org/About:config) what is the mailnews.start_page_override.mstone set to?

Comment 2

9 years ago
Thank you for the fast response.

It is set to:

Others are set to:
If you shut down Thunderbird and look in your prefs.js (located in your profile, http://kb.mozillazine.org/Profile_folder_-_Thunderbird) what is the mailnews.start_page_override.mstone set to this time?

Two other ideas:

- Have you tried starting up in safe mode? (no extensions enabled)
- Have you looked at the error console to see if there is anything relevant? (Tools -> Error Console).

Comment 4

9 years ago
The prefs.js says:
user_pref("mailnews.start_page_override.mstone", "3.0b3");

- I have no extensions installed so I am not sure if safe mode helps but I can try
- Error Console says:
Error: gFolderDisplay is null
Source: chrome://messenger/content/mailWindowOverlay.js
Line: 321

function InitMessageMenu()
  var selectedMsg = gFolderDisplay.selectedMessage; (321)
  var isNews = gFolderDisplay.selectedMessageIsNews;
  var isFeed = gFolderDisplay.selectedMessageIsFeed;

Comment 5

9 years ago
add the following to comment 0 ... Florian writes: 

"actually only [happens] if I used my profile with Windows. I have OS X and Win XP running on my Mac. Thunderbird is installed on both OS and they use the same profile. This works very good. I have all my mails and stuff synchronized. The only bug I have is after I used TB under Win XP, TB under OS X keeps popping up the "whats new" Tab for a couple of times."
Summary: "Whats New" - Tab keeps appearing after reboot → "Whats New" - Tab keeps appearing after reboot using shared profile
Version: unspecified → 3.0
One question would then be is TB the same version (e.g. 3.0b4) on both Windows & OS X? If it isn't the milestone will be set differently which will cause the what's new page to be shown.

Comment 7

9 years ago
Thanks for the hint. My TB on OS X as 3.0 and on Win 2.0. Now everything is fine after one test.

Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 8

9 years ago
not a bug, so invalid
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.