If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash with Minefield 3.7 and DOM Inspector 2.0.3 [@ XPCConvert::NativeInterface2JSObject]

VERIFIED WORKSFORME

Status

()

Core
XPConnect
--
critical
VERIFIED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Sascha Grage, Unassigned)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090815 Minefield/3.7a1pre
Build Identifier: DOM Inspector 2.0.3

DOM Inspector 2.0.3
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090815 Minefield/3.7a1pre

When i open DOM-Inspector -> Accessible Tree, Firefox crashes



Error Console:
Error: uncaught exception: [Exception... "Could not convert Native
argument"  nsresult: "0x8057000a (NS_ERROR_XPC_BAD_CONVERT_NATIVE)"
location: "JS frame ::
chrome://inspector/content/viewers/accessibleTree/accessibleTree.js ::
getDOMNodeFor :: line 416"  data: no]


Crash report:
http://crash-stats.mozilla.com/report/pending/6a7c8336-0a93-476d-90a5-f0ea52090816

Reproducible: Always

Steps to Reproduce:
1. Open DOM Inspector
2. Select Accessible Tree -> http://freakm941.de/usenet/DOM_Inspector--2009-08-15.png
3.
Actual Results:  
Crash

Expected Results:  
No crash

Comment 1

8 years ago
Signature	XPCConvert::NativeInterface2JSObject(XPCLazyCallContext&, int*, nsIXPConnectJSObjectHolder**, nsISupports*, nsID const*, XPCNativeInterface**, nsWrapperCache*, JSObject*, int, int, unsigned int*)
UUID	6a7c8336-0a93-476d-90a5-f0ea52090816
Time 	2009-08-16 05:05:38.600927
Uptime	8261
Last Crash	55065 seconds before submission
Product	Firefox
Version	3.7a1pre
Build ID	20090815045025
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 15 model 2 stepping 9
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x2c
User Comments	
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	XPCConvert::NativeInterface2JSObject 	js/src/xpconnect/src/xpcconvert.cpp:1111
1 	xul.dll 	XPCConvert::NativeData2JS 	js/src/xpconnect/src/xpcconvert.cpp:471
2 	xul.dll 	XPCVariant::VariantDataToJS 	js/src/xpconnect/src/xpcvariant.cpp:674
3 	xul.dll 	xpc_qsVariantToJsval 	js/src/xpconnect/src/xpcquickstubs.cpp:1130
4 	xul.dll 	nsIDOM3Node_SetUserData 	obj-firefox/js/src/xpconnect/src/dom_quickstubs.cpp:5118
5 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1227
6 	js3250.dll 	js_InternalInvoke 	js/src/jsinterp.cpp:1434
7 	js3250.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5124
8 	xul.dll 	XPC_SJOW_CallWrapper 	js/src/xpconnect/src/XPCSafeJSObjectWrapper.cpp:553
9 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1371
10 	js3250.dll 	js_fun_apply 	js/src/jsfun.cpp:2042
11 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:2167
12 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1379
13 	js3250.dll 	js_InternalInvoke 	js/src/jsinterp.cpp:1434
14 	js3250.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5124
15 	xul.dll 	XPC_SJOW_Call 	js/src/xpconnect/src/XPCSafeJSObjectWrapper.cpp:877
16 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1371
17 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:2199
18 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1379
19 	js3250.dll 	js_InternalInvoke 	js/src/jsinterp.cpp:1434
20 	js3250.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5124
21 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2097
22 	xul.dll 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:247
23 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1034
24 	xul.dll 	nsEventListenerManager::HandleEvent 	content/events/src/nsEventListenerManager.cpp:1140
25 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:308
26 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:539
27 	xul.dll 	nsEventDispatcher::DispatchDOMEvent 	content/events/src/nsEventDispatcher.cpp:601
28 	xul.dll 	nsEventListenerManager::DispatchEvent 	content/events/src/nsEventListenerManager.cpp:1267
29 	xul.dll 	nsDOMEventRTTearoff::DispatchEvent 	content/base/src/nsGenericElement.cpp:1677
30 	xul.dll 	nsContentUtils::DispatchTrustedEvent 	content/base/src/nsContentUtils.cpp:3187
31 	xul.dll 	nsPLDOMEvent::Run 	content/events/src/nsPLDOMEvent.cpp:65
32 	xul.dll 	nsContentUtils::AddScriptRunner 	content/base/src/nsContentUtils.cpp:4467
33 	xul.dll 	nsPLDOMEvent::RunDOMEventWhenSafe 	content/events/src/nsPLDOMEvent.cpp:80
34 	xul.dll 	nsTreeSelection::FireOnSelectHandler 	layout/xul/base/src/tree/src/nsTreeSelection.cpp:844
35 	xul.dll 	nsTreeSelection::Select 	layout/xul/base/src/tree/src/nsTreeSelection.cpp:394
36 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
37 	xul.dll 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:2710
Severity: normal → critical
Component: DOM Inspector → XPConnect
Keywords: crash
Product: Other Applications → Core
QA Contact: dom-inspector → xpconnect
Summary: Chrash with Minefield 3.7 and DOM Inspector 2.0.3 → Crash with Minefield 3.7 and DOM Inspector 2.0.3 [@ XPCConvert::NativeInterface2JSObject]
Version: unspecified → Trunk

Comment 2

8 years ago
Confirmed. Easily reproduced here on Linux.
bp-9f9064b6-4fed-48b6-92ba-effb92090816
I end in XPCWrappedNativeScope::FindInJSObjectScope instead of stopping at XPCConvert::NativeInterface2JSObject, however.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Sascha, i don't see this menu when using DOMi on OS X.
(Reporter)

Comment 4

8 years ago
Under the address bar, on the left side, is a small arrow. Click on it...

btw:
On my new OS(Win7x64), i can't reproduce the bug. 
DOM Inspector works without problems with 
"Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) 
Gecko/20091014 Minefield/3.7a1pre"
Ah ok. Thanks. Looks like that it is not existent on OS X. Testing with the recent Minefield on Windows XP and Linux doesn't crash the browser too. I would say lets close this bug. Dave, if you are still able to reproduce the crash feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 6

8 years ago
Retested and crash is gone for me too.
Status: RESOLVED → VERIFIED

Comment 7

8 years ago
There are still some errors coming from this and other menu items here, though. Filed bug 522338 for them.
(Assignee)

Updated

6 years ago
Crash Signature: [@ XPCConvert::NativeInterface2JSObject]
You need to log in before you can comment on or make changes to this bug.