Closed Bug 510775 Opened 12 years ago Closed 12 years ago

Global Search doesn't work with Japanese search terms

Categories

(Thunderbird :: Search, defect)

x86
Windows Vista
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: f.g.superman, Unassigned)

References

Details

(Whiteboard: [fixed by bug #472764])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3pre) Gecko/20090815 Shredder/3.0b4pre

1. Fresh profile, set up google imap account, use all default settings except Tools > Options > Advanced > General > "Enable Global Search and Indexer" is ticked. Restart.

2. Select the All Mail folder.

3. Sanity check: Use the old quick-search bar to search for a Japanese term that exists in some messages. In my case, I searched for "登録" ("registration"). E.g., in one message subject line it appears as "ユーザー登録を続けてください" ("please continue your user registration"). No. of search results: 2.

4. Now try the same search using the Global Search bar.

5. Number of search results: 0.

I also tried putting an asterisk after/before the Japanese search term, but that didn't work either.

Reproducible: Always
This at least depends on bug 472764 - it might be a duplicate too.
Depends on: 472764
I agree to Ludovic: it is a dupe.
Also bug #507632 I think is a dupe of bug #472764.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Can we make sure to revisit when the blocking bug lands ? how about using a whiteboard status ?
good idea. reporters (and others) may not always know they should take some responsibility to check their bugs after some action occurs in another bug.
Whiteboard: [recheck after bug 472764 fixed]
Version: unspecified → Trunk
Component: Mail Window Front End → Search
QA Contact: front-end → search
Is this something I can test again now that bug 472764 is fixed? If yes, should I wait for the next beta/RC and test with that?
(In reply to comment #5)
> Is this something I can test again now that bug 472764 is fixed? If yes, should
> I wait for the next beta/RC and test with that?

Read http://groups.google.ca/group/mozilla.dev.apps.thunderbird/browse_thread/thread/bf4fe06f0e0b20aa# for instructions. And give us Feedback tomorrow.
Searching Japanese seems to work fine now. Tested the 20091023 zip build with a clean profile.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Whiteboard: [recheck after bug 472764 fixed] → [fixed by bug #472764]
You need to log in before you can comment on or make changes to this bug.