Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Omit "--- Comment 0" line for new bugs

RESOLVED FIXED in Bugzilla 3.4

Status

()

Bugzilla
Email Notifications
--
minor
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Frederic Peters, Assigned: Frédéric Buclin)

Tracking

({regression})

3.4.1
Bugzilla 3.4
regression
Bug Flags:
approval +
approval3.4 +

Details

Attachments

(1 attachment)

786 bytes, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en; rv:1.9.0.12) Gecko/20080528 Epiphany/2.22 (Debian/2.26.3-1)
Build Identifier: 

The bugmails for submitted bugs include a comment header:
  --- Comment #0 from Frederic Peters <fpeters@0d.be> 2009-08-16 18:11:06 UTC ---

In the old GNOME bugzilla install those didn't exist.


Reproducible: Always
(Reporter)

Comment 1

8 years ago
Note this doesn't happen on this bugzilla installation (3.2.4).

FWIW the issue was initially reported, with a patch, as http://bugzilla.gnome.org/show_bug.cgi?id=591999
(Reporter)

Comment 2

8 years ago
Looks like this was introduced with bug 457657
(Assignee)

Comment 3

8 years ago
Yes, looks like we remove the |if $count| check in bug 457657.
Severity: enhancement → minor
Status: UNCONFIRMED → NEW
Depends on: 457657
Ever confirmed: true
Keywords: regression
OS: Linux → All
Hardware: x86 → All
Target Milestone: --- → Bugzilla 3.4
Version: unspecified → 3.4.1
(Assignee)

Comment 4

8 years ago
Created attachment 396016 [details] [diff] [review]
patch, v1

The right patch in the right bug...
Assignee: email-notifications → LpSolit
Status: NEW → ASSIGNED
Attachment #396016 - Flags: review?(mkanat)

Updated

8 years ago
Attachment #396016 - Flags: review?(mkanat) → review+

Updated

8 years ago
Flags: approval3.4+
Flags: approval+
(Assignee)

Comment 5

8 years ago
tip:

Checking in template/en/default/email/newchangedmail.txt.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/email/newchangedmail.txt.tmpl,v  <--  newchangedmail.txt.tmpl
new revision: 1.15; previous revision: 1.14
done

3.4.1:

Checking in template/en/default/email/newchangedmail.txt.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/email/newchangedmail.txt.tmpl,v  <--  newchangedmail.txt.tmpl
new revision: 1.12.2.3; previous revision: 1.12.2.2
done
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.