Apostrophes replaced with either kanji character or boxes with letters.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
trivial
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Melissa S., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-1], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

Apostrophes are replaced with either kanji character or boxes with letters in some pages, at random intervals when unicode UTF-8 is selected for character encoding.

Reproducible: Sometimes

Steps to Reproduce:
1.http://www.theupsstore.com/products/maiandpos.html 
2.Toggle to Western (ISO 8859-1) and back to Unicode changes kanji into boxes
3.See also http://img.photobucket.com/albums/v682/meowwl/Firefoxunicodebug.jpg
Actual Results:  
Apostrophes showed up as boxes, or kanji.

Expected Results:  
apostrophe should show up as ' 

There isn't always consistency in this bug, sometimes a page will display the apostrophes as normal, sometimes as boxes with FFFD in them, sometimes as kanji.

This seems similar to the ampersand bug in an older version of firefox, where & was replaced with &
Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Also, please consider using the most recent Firefox 4 beta build, your bug may be resolved there.
Whiteboard: [CLOSEME 2011-1-1]
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe
> mode? If not, please close. These links can help you in your testing.
> http://support.mozilla.com/kb/Safe+Mode
> http://support.mozilla.com/kb/Managing+profiles
> Also, please consider using the most recent Firefox 4 beta build, your bug may
> be resolved there.

I haven't tried it in safe mode. It still happens in normal mode. Apostrophes appear either as boxes or oddball european characters now, instead of kanji, even with the latest official release.

Current version info 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

7 years ago
Seems to be resolved in 3.16.13.
Resolution: INCOMPLETE → FIXED

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.