If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Message display does not show presence of attachments

RESOLVED DUPLICATE of bug 535652

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 535652
8 years ago
7 years ago

People

(Reporter: Roman Fiedler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1

When receiving pgp signed mail with signature attachment, but not special handler plugin installed (e.g. enigmail), seamonkey does not even show that an attachment exists. The behavior to be independent of the mail.inline_attachments flag

Reproducible: Always

Steps to Reproduce:
Send a mail to your account using telnet including:

Content-Type: multipart/signed; micalg="pgp-sha1"; protocol="application/pgp-signature"; boundary="=-/MbGSGJ3LNNQMfvWABtF"

--=-/MbGSGJ3LNNQMfvWABtF
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: base64

w7xiZXLDvGJlcsO8YmVyw7xiZXINCg0K


--=-/MbGSGJ3LNNQMfvWABtF
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEABECAAYFAkqJOy4ACgkQafAcTZYKVBxUiACeNRuqsnN4fYKlPt2/aJCHCaDZ
EmoAnjWMh+S3FELMfJpsPhWYWo6JvK+k
=h0sQ
-----END PGP SIGNATURE-----

--=-/MbGSGJ3LNNQMfvWABtF--
Actual Results:  
Just shows the content of the first part, but hides presence of next part.

Expected Results:  
List signature.asc in attachments list.

Comment 1

8 years ago
Please, testing in today version SeaMonkey 2.0pre, which have implement bug 517238 .
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
Tested with 2.0 std release, where attachment is not shown. Could it be that the mime is broken? What's the desired result from specification side?

Would it make sense to test with pre also?
(Reporter)

Comment 3

8 years ago
Also tested with 2009-11-11 Seamonkey-2.1a1pre.en-US.linux-i686, where behavior is the same.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 535652
You need to log in before you can comment on or make changes to this bug.