Closed Bug 510879 Opened 11 years ago Closed 11 years ago

InputHandler.js can thrown an error on a quadruple click

Categories

(Firefox for Android Graveyard :: General, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: vingtetun, Assigned: froystig)

References

Details

On a quadruple click + a little pan InputHandler thrown an error: 
JavaScript error: chrome://browser/content/InputHandler.js, line 730: this._downUpEvents[1] is undefined

The console dump are the following: 
doing single click with 3
      mousedown :: 0 :: 3
      mouseup :: 0 :: 3
      mousedown :: 0 :: 1
Enter in _doClick
*** elementFromPoint: page  739.8963730569949 , 220.7253886010363 
Enter in _doClick
*** elementFromPoint: page  739.8963730569949 , 220.7253886010363 
Enter in _doClick
doing double click with 4
      mousedown :: 0 :: 1
      mouseup :: 0 :: 1
      mousedown :: 0 :: 2
      mouseup :: 0 :: 2
*** elementFromPoint: page  739.8963730569949 , 220.7253886010363 
@@@ zoomElement is [object XPCNativeWrapper [object HTMLImageElement @ 0xb0cecfc0 (native @ 0xb0c91150)]] ::  :: 
getBoundingContentRect: clientRect is at 112.5, 0; scrolls are 0, 0
zoom from element at 87, 0 by dragging -1, 81
*** elementFromPoint: page  912.5815947779342 , 340.4582106745168 
Enter in _doClick
*** elementFromPoint: page  913.8615128631768 , 340.4582106745168 
Enter in _doClick
doing single click with 0
JavaScript error: chrome://browser/content/InputHandler.js, line 730: this._downUpEvents[1] is undefined
Assignee: nobody → froystig
I can't reproduce this problem with current code.  I think it's been resolved by other click changes.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Can't reproduce on Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.2a2pre) Gecko/20090916
Fennec/1.0b4pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.