Titlebar text is wrong when switch between Month/Multiweek

VERIFIED FIXED in 1.0b2

Status

Calendar
Lightning Only
--
trivial
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: Pete Riley, Assigned: Fallen)

Tracking

unspecified
1.0b2

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Lightning 1.0pre 2009-08-17 / Thunderbird 3.0 beta 3

When I switch between Month and Multiweek views, the titlebar text becomes different than the text that Thunderbird Beta uses.

Example when I click on mail tab:
"Inbox - Local Folders - Mozilla Thunderbird 3.0 Beta 3"

Example when I click on calendar tab and switch from Multiweek to Month view (or probably any views):
"August 2009 - Thunderbird"

I'm wondering if Thunderbird has a variable that Lightning could use to make the titlebar always be consistent.

It doesn't bother me visually.  I'm writing this bug because I use automation software and it's harder to automate windows whose titlebar text isn't consistent.

Reproducible: Always




For reference, there's also Bug 399361 ("Titlebar shows wrong description after stand by").
This works for me using Thunderbird 3.0 and a recent Lightning 1.0b2pre nightly build on Windows XP. The text in the titlebar always ends " - Mozilla Thunderbird".

Peter, can you still reproduce this issue?
(Reporter)

Comment 2

8 years ago
I can still reproduce it using the public release of Thunderbird 3.0 and a  Lightning nightly of 2009-12-13.  When I switch between Month and Multiweek views, the titlebar changes from " - Mozilla Thunderbird" to " - Thunderbird".

However, I've since realized that it's sufficient to just look for a window whose titlebar ends in " Thunderbird", so feel free to close this bug if you want.
(Reporter)

Comment 3

8 years ago
Well, it's resolved for me if I never have to use a Thunderbird nightly again (whose titlebar doesn't end with " Thunderbird").  It was a bit unusual but I had to start using TB nightlies to fix a major crashing bug with one of the public betas.
(Reporter)

Comment 4

8 years ago
I've tracked this down to the following:

In Thunderbird's installation folder:
...\Chrome\en-US.jar\locale\en-US\branding\brand.dtd and
...\Chrome\en-US.jar\locale\en-US\branding\brand.properties

there are these entries:
<!ENTITY  brandShortName        "Thunderbird">
<!ENTITY  brandFullName         "Mozilla Thunderbird">

The Lightning code is using brandShortName for the titlebar but apparently the Thunderbird code is using brandFullName.

Comment 5

8 years ago
The title is set here: http://mxr.mozilla.org/comm-1.9.1/source/calendar/base/content/calendar-views.js#845
(Assignee)

Comment 6

8 years ago
Created attachment 430955 [details] [diff] [review]
Fix - v1
Assignee: nobody → philipp
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #430955 - Flags: review?(ssitter)

Updated

8 years ago
Attachment #430955 - Flags: review?(ssitter) → review+
(Assignee)

Comment 7

8 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/1bdaa5d0b1cf>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0b2
(Reporter)

Comment 8

8 years ago
Thanks, I'll test it when TB 3.1 is released and I can use Lightning nightlies again.
(Reporter)

Comment 9

7 years ago
Verified on Vista using TB 3.1.2 and Lightning 1.0 beta 2.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.