Subfolders are not visible

RESOLVED DUPLICATE of bug 506095

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 506095
9 years ago
8 years ago

People

(Reporter: Matěj Cepl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.9.1.2) Gecko/20090803 Fedora/3.5.2-2.fc11 Firefox/3.5.2
Build Identifier: ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.1/thunderbird-3.0b4pre.en-US.linux-i686.tar.bz2

(originally filed as https://bugzilla.redhat.com/show_bug.cgi?id=517735)

Description of problem:
Some subfolders are not visible within my Gmail account (IMAP access).
This is a new problem, it happened after upgrading RPM packages yesterday
(August 15th). The problem was not visible before July 15th.
This problem is not reproduced under Windows with Thunderbird 3.0b3.

Version-Release number of selected component (if applicable):
3.0-2.6.b3.fc11
I've tried the following versions of Thunderbird:
ftp://ftp.mozilla.org/pub/thunderbird/releases/3.0b2/linux-i686/fr/thunderbird-3.0b2.tar.bz2
ftp://ftp.mozilla.org/pub/thunderbird/releases/3.0b3/linux-i686/fr/thunderbird-3.0b3.tar.bz2
ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.1/thunderbird-3.0b4pre.en-US.linux-i686.tar.bz2

I can reproduce the problem with 3.0b3 and 3.0b4pre.
I cannot reproduce it with 3.0b2.

How reproducible:
Always.

Steps to Reproduce:
1. View a Gmail account via IMAP.
2. Try to view subfolders.

Actual results:
Subfolders are not visible.

Expected results:
Subfolders are visible.

Additional info:
I've tried reproducing the problem with with two non-Gmail
accounts (Microsoft Exchange IMAP4 service) with lots of
subfolders without success. The problem is not necessarily with
Gmail though, it could be a problem with existing subfolders
vs. new subfolders.  In any case I wasn't able to reproduce the
problem with the same Gmail account on Windows.


Reproducible: Always

Steps to Reproduce:
1.see above
2.
3.
Actual Results:  
some folders are not visible

Expected Results:  
I can see anything on the GMail IMAP access
Did you try to subscribe the folders ?
For Gmail IMAP case : Dup of Bug 506095?
For non-Gmail IMAP case: Get IMAP log. XLIST is supported by your IMAP server?
> https://wiki.mozilla.org/MailNews:Logging

> In any case I wasn't able to reproduce the problem with the same Gmail account on Windows.

Same Gmail IMAP account setting? Please note that Bug 506095 doesn't occur if "Show only subscribed folders" is unchecked.

> I can reproduce the problem with 3.0b3 and 3.0b4pre.
> I cannot reproduce it with 3.0b2.

XLIST support which produced Bug 506095 was landed on 3.0b3.
(In reply to comment #2)
> For Gmail IMAP case : Dup of Bug 506095?

It's a Gmail account.

> For non-Gmail IMAP case: Get IMAP log. XLIST is supported by your IMAP server?
> > https://wiki.mozilla.org/MailNews:Logging
> 
> > In any case I wasn't able to reproduce the problem with the same Gmail account on Windows.
> 
> Same Gmail IMAP account setting? Please note that Bug 506095 doesn't occur if
> "Show only subscribed folders" is unchecked.

What version of TB are you using on windows ?
(Reporter)

Comment 4

9 years ago
"me" in the original description of the bug was our reporter. Asking him to join this bug.

Comment 5

9 years ago
Hi,

I'm the original reporter.

About the Gmail case: "Show only subscribed folders" is checked. So it may be unrelated to Bug 506095.

About the non-Gmail case: I do not have access to the non-Gmail servers, I don't know whether they support XLIST or not.

About the IMAP log, just to make sure: It works just fine with the non-Gmail account, there's a problem with the Gmail account only. Do you need logs for the non-Gmail account? The Gmail account?

I tried the same version 3.0b3 on Windows and Linux. Account settings should be identical or at least very similar on both platforms: I set up the account the same day using the same doc.

Comment 6

9 years ago
Created attachment 395042 [details]
Advanced settings: "Show only subscribed folders" is checked

Comment 7

9 years ago
I misread the "Show only subscribed folders" part. Checking again:
* I can reproduce the problem when "Show only subscribed folders" is checked.
* The problem goes away when "Show only subscribed folders" is not checked.

So yes, it's probably related to Bug 506095.

Comment 8

9 years ago
Finally, the problem cannot be reproduced on Windows, whether "Show only subscribed folders" is checked or not.
Depends on: 506095
Bug 493455 has been fixed and is already landed on trunk.
Dimitri Papadopoulos(bug opener), can you reproduce problem on Linux with newest nightly build?
Closing as DUP of Bug 506095. If it's wrong, reopen, please.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 506095
I cannot reproduce the problem with today's nightly build.
The problem has been fixed as far as I'm concerned.
You need to log in before you can comment on or make changes to this bug.