Dialogs force Fennec back into fullscreen mode

VERIFIED DUPLICATE of bug 512575

Status

--
major
VERIFIED DUPLICATE of bug 512575
9 years ago
5 years ago

People

(Reporter: dougt, Assigned: dougt)

Tracking

Trunk
ARM
Maemo

Details

Attachments

(1 obsolete attachment)

(Assignee)

Description

9 years ago
Steps to reproduce:

1) launch fennec (on the trunk fennec goes to fullscreen via sizemode=fullscreen)

2) using the fullscreen toggle button, toggle the fullscreen

3) go to a page the brings up a dialog (like a universal xpconnect permissions dialog)

4) accept/deny the dialog


Actual result:

The fennec window is forced back into fullscreen

Expected result:

The fennec window is left in the non-fullscreen state.
(Assignee)

Comment 1

9 years ago
Created attachment 394999 [details] [diff] [review]
patch v.1

might have to also do something like this on windows mobile.
Attachment #394999 - Flags: review?(pavlov)
(Assignee)

Updated

9 years ago
Flags: wanted-fennec1.0?
(Assignee)

Updated

9 years ago
tracking-fennec: --- → ?
Flags: wanted-fennec1.0?
(Assignee)

Updated

9 years ago
Attachment #394999 - Attachment is obsolete: true
Attachment #394999 - Flags: review?(pavlov)
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 512575
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Component: Linux/Maemo → General
Hardware: All → ARM
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.