If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Accepting invitation into Google Calendar (CalDAV) fails with error 403 "Cannot create/update events where you are not the organizer"

RESOLVED WONTFIX

Status

Calendar
Provider: CalDAV
P1
major
RESOLVED WONTFIX
8 years ago
4 years ago

People

(Reporter: Steve Holl, Unassigned)

Tracking

Lightning 0.9
x86
Mac OS X

Details

(Whiteboard: [CalDAV server: Google])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: 3.0b3 for Thunderbird / 1.0pre for Lightning

I have a non-gmail email address that I receive meeting invites on, which when I hit 'accept' in thunderbird I want to add to my gmail calendar.

I am integrating with CalDav to Google Calendar.

However, When I click 'Accept' for the invite, I get 'MODIFICATION_FAILED' and then I get a yellow warning triangle next to the calendar account in lightning.  I have to then restart thunderbird for the triangle to go away.  The invite acceptance email is never sent.

It looks like others are seeing the same issue, as noted at the link below, and another has confirmed this issue on the newsgroup:
http://forums.mozillazine.org/viewtopic.php?f=46&t=1113165

I have the email address under the calendar set to the email address which I am receiving the email invitations on.  Maybe it is worth noting that email address appears in the list twice, although selecting either renders the same result.

Here are some of the relevant settings from the Config Editor:
calendar.invitations.autorefresh.enabled=true
calendar.google.enableEmailInvitations=true
calendar.google.calPrefs.<email>.googleuser=true
calendar.caldav.sched.enabled=false

I am running Tbird 3.0b3 with Lightning 1.0pre, but the issue was also seen with the most recent Tbird 2 and Lightning 0.9 release.


This may be the same root cause as 498251.

Reproducible: Always

Steps to Reproduce:
1. Receive meeting invite on a non-gmail email address (I haven't tested with it addressed to a gmail address).
2. Click 'accept' on the meeting invite.
3. Observe MODIFICATION_FAILED error and warning icon near the calendar entry.
Actual Results:  
Invite is not responded to, and if I recall, the meeting isn't properly added to the calendar.

Expected Results:  
Clicking accept should add the event to the remote calendar and send an email notification to the creator of the meeting invite.
(Reporter)

Updated

8 years ago
Priority: -- → P1
Version: unspecified → Lightning 0.9

Comment 1

8 years ago
To get more information for the CalDAV developers I suggest the following:

1) Unfortunately the MODIFICATION_FAILED message is useless in most cases. Open Tools > Error Console and check if it contains more information about the reason for the failure.

2) Set the advanced preference "calendar.debug.log" to true and restart Thunderbird. Open Tools > Error Console and clear the content. Repeat to steps to reproduce the failure and proceed with 1) 

3) Retest with other CalDAV server. It would be useful to know if this is an error in Lightning or in the Google Calendar CalDAV implementation.
Whiteboard: [CalDAV server: Google]
(Reporter)

Comment 2

8 years ago
I don't have another calendar provider to test Lightning via CalDav with and rule out if the issue is specific to Gcal or Lighting.

The Error console does shed more light on the issue.  Gcal is returning a 403 since I am trying to add an event where I am not the organizer.  That error makes no sense to me, since it's a pretty basic feature of a calendar to add events other people have organized.  Is lighting sending the wrong function call and trying to create an new meeting under another organizer's name instead of adding simply an event?



Here is the error log.  Verbose errors were also enabled:

CalDAV: itemUri.spec = https://www.google.com/calendar/dav/smholl@gmail.com/events/040000008200E00074C5B7101A82E00800000000606A9E5FB420CA0100000000000000001000000023A98D8301D4D4469F566115E52036AB.ics

CalDAV: send: BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VEVENT
CREATED:20090819T140400Z
LAST-MODIFIED:20090819T150836Z
DTSTAMP:20090819T150836Z
UID:040000008200E00074C5B7101A82E00800000000606A9E5FB420CA0100000000000000
 001000000023A98D8301D4D4469F566115E52036AB
SUMMARY:Understanding CVP Call Flows [RTP-MS]
PRIORITY:5
STATUS:CONFIRMED
ORGANIZER;CN=Steve Holl (sholl):mailto:work-email@changed.com
ATTENDEE;RSVP=TRUE;CN=RTP12-1-MADRID (14) CP;PARTSTAT=NEEDS-ACTION;ROLE=RE
 Q-PARTICIPANT:mailto:coworker@changed.com
ATTENDEE;RSVP=TRUE;CN=Steve Holl (sholl);PARTSTAT=NEEDS-ACTION;ROLE=REQ-PA
 RTICIPANT:mailto:work-email@changed.com
ATTENDEE;PARTSTAT=ACCEPTED;ROLE=REQ-PARTICIPANT:mailto:smholl@gmail.com
DTSTART:20090922T180000Z
DTEND:20090922T200000Z
LOCATION:RTP12-1-MADRID
DESCRIPTION:Arun will be giving a training to help demystify CVP call flow
 s.\n
SEQUENCE:0
TRANSP:OPAQUE
X-MICROSOFT-CDO-BUSYSTATUS:BUSY
X-MICROSOFT-CDO-INSTTYPE:0
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-OWNERAPPTID:-7108647
X-MICROSOFT-CDO-APPT-SEQUENCE:0
X-MICROSOFT-CDO-ATTENDEE-CRITICAL-CHANGE:20090819T140400Z
X-MICROSOFT-CDO-OWNER-CRITICAL-CHANGE:20090819T140400Z
X-MOZ-RECEIVED-SEQUENCE:0
X-MOZ-RECEIVED-DTSTAMP:20090819T140400Z
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT15M
DESCRIPTION:Default Mozilla Description
END:VALARM
END:VEVENT
END:VCALENDAR



CalDAV: recv: <HTML>
<HEAD>
<TITLE>Cannot create/update events where you are not the organizer</TITLE>
</HEAD>
<BODY BGCOLOR="#FFFFFF" TEXT="#000000">
<H1>Cannot create/update events where you are not the organizer</H1>
<H2>Error 403</H2>
</BODY>
</HTML>


CalDAV: Unexpected status adding item to smholl@gmail.com: 403

Warning: There has been an error reading data for calendar: smholl@gmail.com.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_PUT_ERROR. Description: There was an error storing the item on the server.

Error: An error occurred when writing to the calendar smholl@gmail.com! Error code: MODIFICATION_FAILED. Description: 
Source File: file:///Users/sholl/Library/Thunderbird/Profiles/ef8zrae9.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///Users/sholl/Library/Thunderbird/Profiles/ef8zrae9.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js
Line: 997

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIWebNavigation.loadURI]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://global/content/viewSource.js :: viewSource :: line 221"  data: no]
(Reporter)

Comment 3

8 years ago
Created attachment 395315 [details]
Error console log during the issue, showing the 403: Cannot create/update events where you are not the organizer

Attaching the error console log as .txt format, too.
This is likely a server side limitation/bug. Google can't create events where you are not the organizer, I've had the same problem with the Provider for Google Calendar. You can probably accept an invitation sent explicitly to your gmail account (i.e where your gmail account user is an attendee), but I'm not sure of that.
(Reporter)

Comment 5

8 years ago
I suppose this would be more of a feature request then, to be able to add events from another organizer email to Gcal.

I believe this functionality worked with Google Provider though--although after the event was added the attendee members were spammed with google invitations (which if that still stands with CalDav, then considering this feature request would be futile, in my opinion).

It would be nice to have some functionality (maybe turned on with a switch in the config editor) to have lightning override the name of the organizer when it goes out to the destination calendar to re-write the organizer field with whatever email address is chosen in the calendar properties' email address.  Should be relatively easy to code, and off hand I can't think of any negative repercussions that it would cause, but I'm not the calendaring expert. :-)

Updated

8 years ago
Summary: Not able to 'accept' invite with CalDav to Gmail → Accepting invitation into Google Calendar (CalDAV) fails with error 403 "Cannot create/update events where you are not the organizer"
Instead of adding delicate workarounds (that will probably also cause invitation spam), I'd suggest to move this bug to Google, see http://code.google.com/p/google-caldav-issues/

I don't think this is practical for core calendar code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Comment 7

8 years ago
This bug has been opened against Google Caldav support:

http://code.google.com/p/google-caldav-issues/issues/detail?id=38

Comment 8

4 years ago
@Philipp:
maybe this link helps - as Roland handled that fine
http://ical.gutentag.ch/forum/viewtopic.php?id=582
You need to log in before you can comment on or make changes to this bug.