I got a gtk menu related crash

RESOLVED WORKSFORME

Status

Core Graveyard
Viewer App
P3
normal
RESOLVED WORKSFORME
19 years ago
10 years ago

People

(Reporter: Mo DeJong, Assigned: Stuart Parmenter)

Tracking

({crash})

Trunk
Sun
Solaris
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
CVS build from Wed Apr 14 on a Solaris Sparc 5.6 box using egcs 1.1.1.

I was using viewer to look at this URL http://www.javaworld.com.
I opened a view source window and later closed it then I resized
the main window. At some point during this process I got this
core dump.

Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkObject'
Segmentation fault (core dumped)

#0  0xee64fd2c in gtk_menu_item_select_timeout (data=0x33bb44)
    at gtkmenuitem.c:638
#1  0xee5067c4 in g_timeout_dispatch (source_data=0x5f4260,
    current_time=0xefffef70, user_data=0x33bb44) at gmain.c:1147
#2  0xee5054a4 in g_main_dispatch (current_time=0xefffef70) at gmain.c:647
#3  0xee505cdc in g_main_iterate (block=1116, dispatch=1) at gmain.c:854
#4  0xee505eec in g_main_run (loop=0x1eb0c8) at gmain.c:912
#5  0xee646164 in gtk_main () at gtkmain.c:475
#6  0xef711b98 in nsAppShell::Run (this=0xaed10)
    at ../../../../widget/src/gtk/nsAppShell.cpp:208
#7  0x21d48 in nsNativeViewerApp::Run (this=0xaa648)
    at ../../../../webshell/tests/viewer/nsGTKMain.cpp:42
#8  0x22080 in main (argc=1, argv=0xeffff234)
    at ../../../../webshell/tests/viewer/nsGTKMain.cpp:97


This is inside the method gtk_menu_item_select_timeout()

gtk_menu_item_select_timeout (gpointer data)
{
  GtkMenuItem *menu_item;

  GDK_THREADS_ENTER ();

  menu_item = GTK_MENU_ITEM (data);
  menu_item->timer = 0;

  if (GTK_WIDGET_IS_SENSITIVE (menu_item->submenu))       (line 638)
    {


(gdb) print menu_item->submenu
$3 = (GtkWidget *) 0x0

So the problem seems to be that this menu item has no submenu.
I am not really sure if this is a mozilla bug or a gtk bug.

Updated

19 years ago
Assignee: rickg → ramiro

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 1

19 years ago
i'll look into this one.

Updated

19 years ago
Assignee: ramiro → pavlov
Status: ASSIGNED → NEW

Comment 2

19 years ago
pavlov

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M6

Comment 3

19 years ago
marking assigned m6

Updated

19 years ago
QA Contact: 3853 → 3849

Comment 4

19 years ago
Updating QA Contact

Comment 5

19 years ago
dejong: do you know what version of GTK you were using?

there was a fix commited in to GTK on April 9 that fixed some code in this area,
but I am not entirely sure that this would fix this.

Updated

19 years ago
Target Milestone: M6 → M7

Comment 6

19 years ago
need more information, unable to duplicate.  moving to m7

Comment 7

19 years ago
Marking M8.  If you plan to fix any of these for m7, mark them so.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 8

19 years ago
i can't reproduce this.

Comment 9

18 years ago
Adding crash keyword
Keywords: crash
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.