Site is fine on IE and Google Chrome but is blocked by Firefox

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
9 years ago
4 years ago

People

(Reporter: giochrono, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

My site is fine in IE and Google chrome and is not on any lists but comes up at a web forgery only on firefox. This happened when I tranfererred my domain to a new host and it was blocked before I even put a site up on it so there couldn't not have been any malicious code placed by myself or a hacker as it was an empty folder when the error started. Please remove my site from the Firefox Phishing list as it is a legitimate site and has no errors and I need it for my business.

Regards

Giorgos Chronopoulos
giochrono@yahoo.co.uk

Reproducible: Always
Firefox is using the google service.
It shouldn't be too hard to click on the "Why was this site blocked" button in the blocking page and read the page including the part about 
"I’ve confirmed that my site is safe, how do I get it removed from the lists?".

marking invalid because I can not see a bug here
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
Except I have done that already countless times and it is still being blocked but only by firefox, so it doesn't seem to be on any other lists as IE and chrome view it fine, so why is it just blocked by firefox.
You forgot to mention that you had a phishing site on your domain :
https://www.phishtank.com/phish_detail.php?phish_id=759489

I submitted the request for removal again but it will take some time.
There is nothing we can do, we are just using the google service.
(Reporter)

Comment 4

9 years ago
Hi,

I couldn't find it before on that list.

Ok, thanks a lot, just wondered why it is only blocked by firefox. It was temporarily allowed for a day after I upgraded to 3.5 but then got blocked again after.

Well I hope that works and soon.

Regards

-Gio
Firefox downloads a database over time with sites that should be blocked.
If it encounters such a site it will ask google if this blocking is still correct or if the database update on your system is only behind.

Not using a database would mean that google would get all URLs that you are visiting which would be a big privacy issue.
Your site was not removed from the blocking with the update, only your local database got removed because of the update. YFirefox blocked it again after Firefox downloaded the lists of blocked sites and stored it in your local database.

Why it's not by Chrome is surprising for me, seems to be a bug in Chrome.
(Reporter)

Comment 6

9 years ago
Well it gave me hope for a day, and them gave it a kicking straight after. Since my site is legit and didn't have any phishing code as it was just a domain I hadn't used yet I wouldn't see allowing my site to be viewed as a bug per se but I get your point of course
(Assignee)

Updated

4 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.