Inaccurate error message while logging in without any credentials

VERIFIED FIXED in 5.1

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: krupa, Assigned: Milos)

Tracking

unspecified
x86
All

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
steps to reproduce:
1.Go to AMO homepage
2.Click on "Log in" link
2.Without proving login email id or password click "log in"
3.Notice the error message

expected result:
error message says-"Email id and password are required fields to login"

actual result:
error message says-"wrong username or password!"

screenshot:http://screencast.com/t/CuAzxe2H87l
This isn't technically wrong and I don't think it's worth spending time on.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

9 years ago
verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

9 years ago
Just noticed-Error message should say-"Wrong Email address or password" instead of "Wrong username or password!".  

reopening for consideration.
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---
(Assignee)

Comment 4

9 years ago
Created attachment 396015 [details] [diff] [review]
patch v1

Changed __Wrong username or password__ to __Wrong Email address or password__
Attachment #396015 - Flags: review?(clouserw)
Comment on attachment 396015 [details] [diff] [review]
patch v1

r50560
Attachment #396015 - Flags: review?(clouserw) → review+
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
verified fixed https://preview.addons.mozilla.org/en-US/firefox/users/login
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Assignee: nobody → bmo
Target Milestone: --- → 5.1
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.