nanojit: don't print guard conditions twice with TMFLAGS=assembly

RESOLVED DUPLICATE of bug 511329

Status

()

RESOLVED DUPLICATE of bug 511329
10 years ago
10 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
Created attachment 395202 [details] [diff] [review]
patch

Currently with TMFLAGS=assembly we get output like this on every xt/xf:

      eq2 = eq ld3, 0
      eq2 = eq ld3, 0
      xf2: xf eq2 -> pc=0x8cc0991 imacpc=(nil) sp+0 rp+0

This patch avoids the duplication.
Attachment #395202 - Flags: review?(jseward)
(Assignee)

Comment 1

10 years ago
This is superseded by bug 511329 -- turns out the extra printing of the guard condition is necessary if you do it after dead code elimination.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 511329
(Assignee)

Updated

10 years ago
Attachment #395202 - Flags: review?(jseward)
You need to log in before you can comment on or make changes to this bug.