Error when creating new component -- must have CC field populated not to cause error

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: tpascaru, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: 3.4.1

When creating a new component, if the CC field is left empty an error occurs:
Software error:

Undef to trick_taint at Bugzilla/Util.pm line 62
	Bugzilla::Util::trick_taint(undef) called at Bugzilla/User.pm line 1685
	Bugzilla::User::login_to_id(undef, 1) called at Bugzilla/Component.pm line 246
	Bugzilla::Component::_check_cc_list('Bugzilla::Component=HASH(0x2ebdbf4)', 'ARRAY(0x1d50774)') called at Bugzilla/Component.pm line 322
	Bugzilla::Component::set_cc_list('Bugzilla::Component=HASH(0x2ebdbf4)', 'ARRAY(0x1d50774)') called at C:\Software\bugzilla\editcomponents.cgi line 237

For help, please send mail to this site's webmaster, giving this error message and the time and date of the error.
[Tue Aug 18 17:39:57 2009] editcomponents.cgi: Undef to trick_taint at Bugzilla/Util.pm line 62 [Tue Aug 18 17:39:57 2009] editcomponents.cgi: Bugzilla::Util::trick_taint(undef) called at Bugzilla/User.pm line 1685 [Tue Aug 18 17:39:57 2009] editcomponents.cgi: Bugzilla::User::login_to_id(undef, 1) called at Bugzilla/Component.pm line 246 [Tue Aug 18 17:39:57 2009] editcomponents.cgi: Bugzilla::Component::_check_cc_list('Bugzilla::Component=HASH(0x2ebdbf4)', 'ARRAY(0x1d50774)') called at Bugzilla/Component.pm line 322 [Tue Aug 18 17:39:57 2009] editcomponents.cgi: Bugzilla::Component::set_cc_list('Bugzilla::Component=HASH(0x2ebdbf4)', 'ARRAY(0x1d50774)') called at C:\Software\bugzilla\editcomponents.cgi line 237 

Reproducible: Always

Steps to Reproduce:
1. Select component: http://<server>/bugs/editcomponents.cgi
2. Select the product: http://<server>/bugs/editcomponents.cgi?product=<product>
3. "Add" a component: http://<server>/bugs/editcomponents.cgi?action=add&product=<product>
4. Enter a component, but leave the "Default CC List:" empty and click on "Add". You will see the error screen.

Comment 1

9 years ago
When you add a new component, you don't trigger the code you are mentioning. editcomponents.cgi line 237 is for existing components, not to create new ones. So you must have something wrong with your installation. Anyway, I just tested with Bugzilla 3.2.4, 3.4.1 and 3.5, and also on Windows, and I cannot reproduce your problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.