Selects don't work correctly in colspan

VERIFIED WORKSFORME

Status

()

Core
HTML: Form Submission
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: johng, Assigned: Eric Pollmann)

Tracking

Trunk
mozilla0.9
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nsbeta3-, URL)

(Reporter)

Description

18 years ago
Can not change vacation mode autoreply back from vacation to off.

Ran into this using the old PR2 public build, think it is still a problem.

Reproduce:
-go to phonebook.mcom.com (a Netscape internal app - sorry mozilla - but it is a 
simple app like others that are on the web)
-go to your username
-press the button to "Edit Person", enter passwords as needed.
-when you can edit your name info, go down to auto-reply, change the setting to 
vacation and put in a msg.

Assuming that last step works (when you go back, the changes are saved), now do 
this.

-go back to this page to turn off your vacation mode.  

Results:
Notice that the autoreply setting is set to "off", not vacation.  But if you go 
there with 4.x, it is set to vacation just like you just set it.

Don't know now these 2 browsers could be different here, but this problem made 
it impossible for me to turn off my vacation msg using Netscape 6 - I had to 
revert to the old 4.x version.

Comment 1

17 years ago
I am not positive, but I think this is a duplicate of Bug 45818, event 
targetting is off on rowspans and I'll bet it is the same for colspans

This is bad and needs to be fixed for nsbeta3, so does bug 45818
Assignee: rods → karnaze
Keywords: nsbeta3
Summary: Form settings not shown or sent correctly → Selects don't work correctly in colspan

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: qawanted

Comment 2

17 years ago
This is not a dup of 45818. Marking nsbeta3- since nobody thought it was 
important enough to develop a test.
Whiteboard: nsbeta3-

Comment 3

17 years ago
Updating QA contact.
QA Contact: ckritzer → vladimire

Comment 4

17 years ago
When I attempt to edit my name in the phonebook I get an error trying to access 
quermai.mcom.com. I'm not sure who should get this, but I'll start with 
Networking.
Assignee: karnaze → gagan
Status: ASSIGNED → NEW
Component: Form Submission → Networking
QA Contact: vladimire → tever

Comment 5

17 years ago
I cannot reproduce this with Linux build 2000100610.  But, since
this is reported as a problem under Win95, perhaps someone can
verify that it is no longer a bug?

Comment 6

17 years ago
->WORKSFORME (WindowsNT build 2000101008)
Reporter, please verify against latest build.

Comment 7

17 years ago
this WFM as far as networking is concerned. but going by the original summary of 
this bug I'd say there probably is more to it. Giving back to Chris.
Assignee: gagan → karnaze

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9

Comment 8

17 years ago
This is still a problem. After setting the autoreply to "vacation" and 
revisiting the phonebook, the autoreply is "off" when editing but "vacation"  
when viewing, so the select was apparantly working ok when it originally got 
set. I tried exiting Mozilla and re-trying and it made no difference. 

I'm not sure who is responsible, but reassigning to pollmann as a first guess.
Assignee: karnaze → pollmann
Status: ASSIGNED → NEW
Component: Networking → Form Submission
(Assignee)

Comment 9

17 years ago
None of the options are selected in the source of the "edit" page, regardless of
what the setting is when we edit our entry.  Here is the relavant excerpt of the
source for the edit page:

<select NAME="autoSelect" onChange="autoReplyChanged()">
<option>off
<option>vacation
<option>reply
<option>echo
</select>

Since none are selected, we select the first by default.  Marking INVALID as
this is most likely a server side problem.  I'll contact the phonebook guru and
see if we can get it fixed.

FWIW, you can still turn off autoreply with 6.x, just leave "off" selected, then
click "save changes".
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 10

17 years ago
-> default qa for form submission.
QA Contact: tever → vladimire

Comment 11

17 years ago
verifying works for me build 2001-06-11-0.9.1
Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.