crash after upgrading from 3.2 to 3.4.1

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: d.pavka, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; uk; rv:1.9.1.2) Gecko/20090730 SUSE/3.5.2-1.2 Firefox/3.5.2
Build Identifier: 3.4.1

After upgrading using instructions http://www.bugzilla.org/docs/3.4/en/html/upgrade.html
bugzilla crashes at enter_bug.cgi?product=[product_name]


Reproducible: Always

Steps to Reproduce:
1.upgrade from 3.2 to 3.4.1 from tarball
2.run checksetup.pl
3.try to add new bug
Actual Results:  
DBD::mysql::db selectall_arrayref failed: Unknown column 'buglist' in 'field list' [for Statement "SELECT id,name,description,type,custom,mailhead,sortkey,obsolete,enter_bug,buglist,visibility_field_id,visibility_value_id,value_field_id FROM fielddefs WHERE custom = ? AND obsolete = ?  ORDER BY sortkey, name"] at Bugzilla/Object.pm line 224
	Bugzilla::Object::_do_list_select('Bugzilla::Field', 'custom = ? AND obsolete = ?', 'ARRAY(0x93e0d80)', 'undef') called at Bugzilla/Object.pm line 206
	Bugzilla::Object::match('Bugzilla::Field', 'HASH(0x93e0d50)') called at Bugzilla/Field.pm line 246
	Bugzilla::Field::match('Bugzilla::Field', 'HASH(0x93e0d50)') called at Bugzilla.pm line 463
	Bugzilla::active_custom_fields('Bugzilla') called at /var/www/bugzilla-3.4.1/enter_bug.cgi line 397

Comment 1

9 years ago
Looks like your upgrade didn't complete. Make sure checksetup.pl didn't throw any error, such as too old or missing required Perl packages. When all required modules are installed, you must run checksetup.pl again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
checksetup.pl didn't throw any errors 
only reported about additional modules

May be there were changes in DB structure?
Because there are no buglist,visibility_field_id,visibility_value_id,value_field_id
fields in fielddefs table
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

9 years ago
(In reply to comment #2)
> May be there were changes in DB structure?
> Because there are no
> buglist,visibility_field_id,visibility_value_id,value_field_id
> fields in fielddefs table

Sure there are. That's the job of checksetup.pl to upgrade the DB schema. Anyway, that's a support question, see http://www.bugzilla.org/support/ for help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → INVALID

Comment 4

8 years ago
This issue was reported to Debian too, see http://bugs.debian.org/589914

If someone know a solution it would be nice to get a feedback to 589914@bugs.debian.org

Thanks,
Raphael

Updated

8 years ago

Comment 5

8 years ago
raphael: it looks like these crashes happen because people are not (properly?) following the instructions for how to upgrade bugzilla.

there's very little we can do, and this isn't the scope of Bugzilla.

http://www.ravenbrook.com/project/p4dti/tool/cgi/bugzilla-schema/index.cgi?action=range&from=3.2&to=3.4.1&view=View+schema

clearly lists the changes, and checksetup.pl is definitely supposed to do the schema updates. which means one of the following:
* the wrong version of checksetup.pl was run
* checksetup.pl ran with the wrong version of bugzilla modules
* checksetup.pl failed
* checksetup.pl wasn't run
* someone restored an old database partially over bugzilla (this can confuse checksetup).

individuals need to determine how they messed up bugzilla. and they can do this by using the support facilities.

it's kind of like installing debian and then deleting half of /etc. It's not a bug that debian stops working, and it isn't a bug in most components of debian that they stop working when half of /etc is missing. But support outlets for debian may choose to help people restore their installation of debian to 'working order'.
You need to log in before you can comment on or make changes to this bug.