Use OpenMAX DL to accelerate Video decoding

RESOLVED DUPLICATE of bug 1224889

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1224889
9 years ago
2 years ago

People

(Reporter: vlad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

On most of our current mobile device targets, OpenMAX is present in one way or another.  The OpenMAX DL layer (Development Layer) has primitives that we can use to accelerate decoding, including things like yuv->rgb conversion, 8x8 IDCT, etc.

See the OpenMAX DL section at http://www.khronos.org/openmax/ for more information.  OpenMAX is available on both Maemo (Maemo 5) and Windows CE/Tegra, and on many non-Tegra Windows Mobile devices.
Component: Audio/Video → Audio/Video: Playback
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1224889
OpenMax *DL* is not the same to OpenMax *IL*, but I don't know what we can benefit from developing our own DL. Do we have clear ways to accelerate decoding per comment 0?
You need to log in before you can comment on or make changes to this bug.