NSS initialization not friendly for libraries

RESOLVED DUPLICATE of bug 453495

Status

NSS
Libraries
RESOLVED DUPLICATE of bug 453495
9 years ago
9 years ago

People

(Reporter: Robert Relyea, Assigned: Robert Relyea)

Tracking

3.12.4
3.12.5
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

9 years ago
There may be a bug for this already, but I quick search did not turn it up.

The basic problem is libraries have not strategy for being able to initialize NSS without perturbing the base application or other libraries use of NSS. This problem is partially solved in system NSS where configuration is the same for a given process and user no matter how initializes the library.

A proposal for how to fix this is presented at 
https://wiki.mozilla.org/NSS_Library_Init

bob

Comment 1

9 years ago
Bob, the old bug you're looking for is bug 453495.
(Assignee)

Comment 2

9 years ago
Thanks wan-teh. I've updated the old bug and closed this one as a dup.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453495
You need to log in before you can comment on or make changes to this bug.