popup menu doesn't pop up in window that appears when a security's symbol is clicked

UNCONFIRMED
Unassigned

Status

UNCONFIRMED
9 years ago
7 years ago

People

(Reporter: tiger, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.14pre) Gecko/2009081901 Camino/2.0b4pre (like Firefox/3.0.14pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.14pre) Gecko/2009081901 Camino/2.0b4pre (like Firefox/3.0.14pre)

this page at Sharebuilder shows the user's portfolio. when the user clicks the stock symbol for any of their securities, a small, unframed (Javascript?) window appears that shows a snapshot of the stock's particulars and has a popup menu at the bottom labeled "Quick Links." the links in this menu take the user to various pages pertaining to the stock - quote, detailed quote, company profile, etc.. its presence and functionality are critical to the site, but the popup menu doesn't work in Camino - neither in 1.6.8 nor in 2.0b4pre (1.9.0.14pre 2009081901). thanks...

Reproducible: Always

Steps to Reproduce:
1. you have to have an account with at least one security position in it at sharebuilder.com.

2. log in and go to the "Current Positions" page for the account.

3. click the symbol of any security in the portfolio.

4. in the window that appears, click the menu at the bottom labeled "Quick Links."
Actual Results:  
the menu is highlighted, but does not open.

Expected Results:  
the menu's supposed to open when clicked.

i'm not using a theme in 2.0b4, though i do have 1Password running in 1.6.8. i doubt that has anything to do with it though because the behavior is identical in both versions. plus, fwiw, it works fine in the current versions of both Safari and Firefox and i'm running 1Password in both of those.

thanks...

Comment 1

9 years ago
A couple of things to try here...

When you say "the current version of Firefox", which version do you mean? Firefox 3.0.x is equivalent to Camino 2.x; Firefox 2.x is equivalent to Camino 1.6.8. (Firefox 3.5.x and beyond are equivalent to some Camino version that doesn't yet exist, but will probably be either Camino 3.0 or Camino 2.5-ish.) If it works normally in either of those two Firefox versions...

...does spoofing your user-agent as (exactly) the equivalent version of Firefox fix the problem? This smells like a UA sniffing issue.

cl
(Reporter)

Comment 2

9 years ago
i mean 3.x, with 'x' being anything you want to put in there.

how do i spoof my UA in Camino? i don't find any reference to it in the menus or prefs...

Comment 3

9 years ago
It's important to know whether you're referring to 3.0.x or 3.5.x, though.

For spoofing a user-agent string, the best thing to use is

http://pimpmycamino.com/parts/user-agent

(though you could also do it manually via about:config if you were so inclined).

cl
(Reporter)

Comment 4

9 years ago
ah, k. well i'm talking about Firefox 3.5.2 (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2) and literally every sub-version of 3.0. it's worked fine in every version of Firefox i've ever used including 2.whatever.

thanks - i'll try spoofing the UA and let you know what happens. after my girlfriend teaches me to make her killer curry, which she insists on doing RIGHT NOW.

Comment 5

9 years ago
Sounds like there's little likelihood of this being some sort of Gecko bug, then. That's good.

Unfortunately, it also sounds likely to be another case of brain-dead browser sniffing :-\
(Reporter)

Comment 6

9 years ago
alas...User Agent has not solved the problem. i chose both Safari 2.0.4 (Intel) and Firefox 2.0 (Intel) and the menu in question still doesn't work.
(Reporter)

Comment 7

9 years ago
oh, and i quit and relaunched Camino after each change, in case that would affect anything. it didn't.
(Reporter)

Comment 8

9 years ago
same story in 1.6.8 with the UA set to Firefox 2.0 (Mac OS X Intel), btw.

Comment 9

9 years ago
Could be bug 258445, but there's no way to tell without being able to access the site.
(Reporter)

Comment 10

9 years ago
would page source help? i can't provide source for the actual window in which the menu appears because it looks to be a javascript thing or something (not a web developer so i can't be sure) - it's not a proper browser window but a frameless floating thing - but i could grab the code for the page that presents that window when a ticker symbol is clicked...
Sam can repro this, and at first look it does not appear like it's one of the missing methods from bug 258445.  

Sam's going to look more when he's not in a meeting, and he'll attach some HTML Complete for us if we don't get answers from his looking.
Component: General → Page Layout
QA Contact: general → page.layout
Sam, pinging you on this and hoping it doesn't get lost in your avalanche of vacation email.

Comment 13

9 years ago
Sam, any progress on this?
Does this still happen with Camino 2.1.2?
You need to log in before you can comment on or make changes to this bug.