Misplaced text cursor in designMode with justify alignment

RESOLVED DUPLICATE of bug 503399

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 503399
8 years ago
7 years ago

People

(Reporter: Jakub Vrána, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

Text cursor is misplaced in designMode and with BrowseWithCaret (F7) feature on lines with justification.

Reproducible: Always

Steps to Reproduce:
1. Go to a page with paragraphs aligned to both sides (justify).
2. Press F7.
3. Click near the end of a line with long spaces.
Actual Results:  
Cursor is not aligned with characters.

Expected Results:  
Cursor aligned with characters.
(Reporter)

Comment 1

8 years ago
Created attachment 395558 [details]
Misplaced cursor

Comment 2

8 years ago
I observed the same bug on Firefox 3.5.3 for Mac OS X and on Firefox 3.0.14 on Ubuntu Linux.
It is especially annoying in wysiwyg-editors that rely on the browser's designMode, like TinyMCE, CKEditor or the Google Docs Text Manipulation Program. Set a paragraph to justified in any of these editors and the cursor is displayed 2 or 3 pixel to the left from its actual position.

Comment 3

8 years ago
I faced the same bug with Seamonkey 2.0.1 on Windows XP. It is very annoying when using SeaMonkey Composer too.

Comment 4

8 years ago
This is a duplicate of bug 425629.

Comment 5

8 years ago
Oops, I meant bug 442847.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 503399
You need to log in before you can comment on or make changes to this bug.