If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

choosing "sort by/Grouped by sort" makes all messages disappear

RESOLVED DUPLICATE of bug 517467

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 517467
8 years ago
8 years ago

People

(Reporter: Edward Rudd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.2) Gecko/20090803 Fedora/3.5.2-2.fc11 Firefox/3.5.2 FirePHP/0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.1) Gecko/20090814 Fedora/3.0-2.6.b3.fc11 Thunderbird/3.0b3

When setting the "Grouped by sort" setting on folders it will cause all of the messages to disappear.  The folder list will still show there is unread messages though.  Switching to a different folder and back will not return my messages.  Rebuilding the mailbox will SOMETIMES fix the issue (until I select group by sort again).


Reproducible: Sometimes

Steps to Reproduce:
1.select a folder and go change the sort to "group by sort" (sorting is by date descending)

Actual Results:  
the messages all disappear

Expected Results:  
the messages to be grouped by date

If a new message is dropped in the mailbox it will sometime fix itself.
Restarting thunderbird will sometimes fix it
going to the ImapMail cache folder in my profile and deleting the mailbox caches will force t-bird to re-fetch the headers

but again if I select "Group by sort" again they will all disappear.
d won't fix it. 
I have offline syncing turned OFF (that's a rather annoying new default! I don't want all 2+GB of my email synced to my local machine.. That's WHY I use IMAP)

It seems to occur when the folder is in the middle of pulling headers or if I change too many options quickly
Anything in the Tools -> Error console ?

Comment 2

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

I just downloaded beta 4 (Windows Vista) and ran into this exact same issue.

Error console:

Error: sortType is undefined
Source File: file:///C:/Program%20Files/Mozilla%20Thunderbird%203.0%20Beta%203/modules/dbViewWrapper.js
Line: 1534
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 517467
You need to log in before you can comment on or make changes to this bug.