null plugin shouldn't ask for deprecated NPNVariables

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: cjones, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

It asks for NPNVserviceManager, which is no longer supported.  This requires it to include some XPCOM headers it shouldn't be.

This causes the null plugin to fail to link with the patches in bug 507082.  As I don't want this to block that patch, I'm going to add a temporary fix in that bug to compile the null plugin with -DXPCOM_GLUE.
The null plugin is no more, AIUI.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.