[Thunderbird] mozilla-central 'Linux comm-central build' do not compile after bug 511326 landing

VERIFIED FIXED in Thunderbird 3.1a1

Status

--
blocker
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: sgautherie, Assigned: karlt)

Tracking

({dogfood, regression})

Trunk
Thunderbird 3.1a1
x86
Linux
dogfood, regression
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Thunderbird/1250807182.1250810003.30323.gz
Linux comm-central build on 2009/08/20 15:26:22

Lots of errors, like:
{
/buildbot/comm-central-trunk-linux/build/mozilla/media/libsydneyaudio/src/sydney_audio_alsa.c:157: undefined reference to `snd_pcm_close'
}
(Reporter)

Updated

9 years ago
Summary: [Thunderbird, Linux] mozilla-central builds do not compile after bug 511326 landing → [Thunderbird] mozilla-central 'Linux comm-central build' do not compile after bug 511326 landing
(Assignee)

Comment 1

9 years ago
Created attachment 395777 [details] [diff] [review]
copy necessary parts from hg-central
[Checkin: Comment 3]

Have a build running now to test.
Assignee: nobody → mozbugz
(Assignee)

Updated

9 years ago
Attachment #395777 - Flags: review?
(Assignee)

Comment 2

9 years ago
Comment on attachment 395777 [details] [diff] [review]
copy necessary parts from hg-central
[Checkin: Comment 3]

Passed test.
(Assignee)

Comment 3

9 years ago
Comment on attachment 395777 [details] [diff] [review]
copy necessary parts from hg-central
[Checkin: Comment 3]

http://hg.mozilla.org/comm-central/rev/84acdee35d53
Attachment #395777 - Flags: review?
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

9 years ago
V.Fixed, per tinderboxes.
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
Target Milestone: --- → Thunderbird 3.0b4
(Reporter)

Updated

9 years ago
Attachment #395777 - Attachment description: copy necessary parts from hg-central → copy necessary parts from hg-central [Checkin: Comment 3]
(Reporter)

Updated

9 years ago
Target Milestone: Thunderbird 3.0b4 → Thunderbird 3.1a1
(Reporter)

Comment 5

9 years ago
Comment on attachment 395777 [details] [diff] [review]
copy necessary parts from hg-central
[Checkin: Comment 3]

>diff --git a/config/static-config.mk b/config/static-config.mk
>@@ -95,16 +95,20 @@ endif
>+ifeq ($(OS_ARCH),Linux)
>+STATIC_EXTRA_LIBS += $(MOZ_ALSA_LIBS)
>+endif
>+

Why isn't this included in an |ifdef MOZ_SYDNEYAUDIO| like in m-c?

Is it actually correct that this patch applies to m-1.9.2 too?
(Assignee)

Comment 6

9 years ago
(In reply to comment #5)
> >+ifeq ($(OS_ARCH),Linux)
> >+STATIC_EXTRA_LIBS += $(MOZ_ALSA_LIBS)
> >+endif
> >+
> 
> Why isn't this included in an |ifdef MOZ_SYDNEYAUDIO| like in m-c?

It doesn't make any difference whether or not it is within MOZ_SYDNEYAUDIO because MOZ_ALSA_LIBS will be empty if MOZ_SYDNEYAUDIO is not defined.
Maybe I didn't think of that when I wrote the patch for m-c.

> Is it actually correct that this patch applies to m-1.9.2 too?

I don't understand what you mean here.
This patch was for comm- not mozilla-.
(Reporter)

Comment 7

9 years ago
(In reply to comment #6)

> Maybe I didn't think of that when I wrote the patch for m-c.

Good. Then, could you update m-c, just to be in sync'?

> I don't understand what you mean here.

c-c is still used on top of either m-c (which has your other patch) or m-1.9.2 (which has not) ... so I wonder why your c-c patch here did not have "ifndef 192".
(Assignee)

Comment 8

9 years ago
(In reply to comment #7)
> (In reply to comment #6)
> 
> > Maybe I didn't think of that when I wrote the patch for m-c.
> 
> Good. Then, could you update m-c, just to be in sync'?

I'm sorry that I didn't do the same on both.  I was acting quickly to solve a bug marked as a blocker.  I can't remember whether I intentionally did something different here but I do recall plenty of other differences at the time.
I've got more urgent things to do than change this.
I'm happy if someone would like to change either m-c or c-c.

> c-c is still used on top of either m-c (which has your other patch) or m-1.9.2
> (which has not) ... so I wonder why your c-c patch here did not have "ifndef
> 192".

OK, IIUC c-c configure.in and config/* gets used to build code from m-1.9.2 (and m-c), which was the cause of this bug.
This will work fine for building m-1.9.2 with c-c.  c-c/m-1.9.2 doesn't need the EXTRA_DSO_LDOPTS changes that landed on m-c because c-c uses a static build.

Is there any plan for a solution to this situation of c-c needing continual updating because it also builds m-*?
You need to log in before you can comment on or make changes to this bug.