Video Plugin layout position not remembered when using scrollwheel when a scroll bar is present

RESOLVED DUPLICATE of bug 507402

Status

()

RESOLVED DUPLICATE of bug 507402
9 years ago
9 years ago

People

(Reporter: mozbugz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090820 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090820 Minefield/3.7a1pre (.NET CLR 3.5.30729)

I been noticing this strange behavior.  If there is a horizontal scrollbar exists on the browser window, and a YouTube video plugin (maybe not all plugins or more than 1 kind of plugin).. when using a scroll wheel to navigate the window up and down from top to bottom edges of the scroll window, and back and again many times causes the plugin to not remember where it should be on the page doing reflow or upon layout updates.

Reproducible: Always

Steps to Reproduce:
1. Open URL
2. Shrink Browser window so its got a scrollbar
3. Click on Video link to load/start YouTube Video
4. Place mouse cursor near left edge of Video
5. Use mouse scrollwheel back and forth many times up and down the page.
Actual Results:  
Plugin jumps around page up and down, not staying within its proper place relative to the rest of the page content when scrolling page up and down with a scrollwheel.

Expected Results:  
Plugin should stay in its proper place relative to its html settings when scrolling page with a scrollwheel

I think I've seen similar odd behavior over on YouTube also.
(Reporter)

Comment 1

9 years ago
Created attachment 395763 [details]
Position 1

1 of 3 images showing various positions of the plugin
(Reporter)

Comment 2

9 years ago
Created attachment 395764 [details]
2 of 3

2 of 3
(Reporter)

Comment 3

9 years ago
Created attachment 395765 [details]
3 of 3

3 of 3
(Reporter)

Comment 4

9 years ago
This appears to be fixed in the latest:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090825 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 507402
You need to log in before you can comment on or make changes to this bug.