Double-click with two clicks on different areas of the page results in zoom of area of second click

VERIFIED FIXED in fennec1.0b5

Status

--
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: aakashd, Assigned: vingtetun)

Tracking

({polish})

Trunk
fennec1.0b5
polish
Bug Flags:
wanted-fennec1.0 ?
in-litmus +

Details

(Whiteboard: [fennecb3testday])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Build Id:

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20090821
Fennec/1.0b3pre

and

Mozilla/5.0 (Macintosh; U; Intel Mac OSX 10.5; en-US; rv:1.9.2a2pre)
Gecko/20090808 Fennec/1.0b3pre

Steps to Reproduce:
1. Reproduce a zoom by double clicking with a single click on two separate parts of the page really quickly.

Actual Results:
The double-click zooms in where the second click occurred.

Expected Results:
The double-click should only zoom when the clicks have occurred within a smaller/distinct area of pixels.
Flags: wanted-fennec1.0?
Flags: in-litmus?
(Reporter)

Updated

9 years ago
Whiteboard: [fennecb3testday]
We could reuse the click radius to determine if the two-parts of the double click are sufficiently close.
(Reporter)

Updated

9 years ago
tracking-fennec: --- → ?

Updated

9 years ago
tracking-fennec: ? → 1.0+
Keywords: polish
Created attachment 401803 [details] [diff] [review]
Patch

If we don't dispatch the double click are we supposed to dispatch 2 single click?
I fear this can possibly results into click that are not really wanted?
Attachment #401803 - Flags: review?(combee)
Comment on attachment 401803 [details] [diff] [review]
Patch

I don't like doing two single clicks, especially if one causes a content change.  I'd prefer to just eat both events here, as this is likely a glitch and not what the user wanted.
Attachment #401803 - Flags: review?(combee) → review-
Assignee: nobody → 21
Created attachment 403215 [details] [diff] [review]
Patch v0.2

* don't dispatch the click if they were too far
* Zoom in the area of the _first_ click if dblClick is in the good radius


The patch needs to be test a bit more on device though.
Comment on attachment 403215 [details] [diff] [review]
Patch v0.2

Code works for me
Attachment #403215 - Flags: review?(combee) → review+
Attachment #401803 - Attachment is obsolete: true
Works for me too

pushed:
https://hg.mozilla.org/mobile-browser/rev/42151c6f6349
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → B5
(Reporter)

Comment 8

9 years ago
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/20091026
Fennec/1.0b5pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20091026
Fennec/1.0b5pre


There's a new bug or two that came out of this, but this is definitely nice to have :).
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

9 years ago
litmus test case 9794 has been created for regression testing this bug.
Flags: in-litmus? → in-litmus+
(Reporter)

Updated

9 years ago
Component: General → Panning/Zooming
You need to log in before you can comment on or make changes to this bug.