Closed Bug 51197 Opened 24 years ago Closed 24 years ago

No reflow on text resize

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: mlei2, Assigned: karnaze)

References

()

Details

Attachments

(1 file)

Not sure if this is in the right component.

Description: When the text size is changed using View\Text Size\*, the page 
should be redrawn to fit the new size, but it is not, so positioning becomes 
wrong.

Steps to reproduce:
1) Load the query page http://bugzilla.mozilla.org/query.cgi
2) Scroll down to fields for summary, description entry, etc. (bug more visible 
there)
3) Change the text size to "Large." If you were at medium before, you'll see 
that the captions are now pushing into the text fields.
4) Change the text size to "Small." Now you see that what should be right-
justified is no longer so.

Expected behavior: On a size change, the page should be redrawn to the new text 
size.

Workaround: Hit "reload" after the text size changes.

Running build 2000090110 windows and 200090108 linux.
this looks like a dup of reopened bug 35681 "[REGRESSION] HTML is sized too wide"
(by way of dup bug 42790 "Text too wide when browsing with enlarged text size.")
Updating QA Contact.
QA Contact: janc → lorca
dupe of bug 35681

*** This bug has been marked as a duplicate of 35681 ***
Status: UNCONFIRMED → RESOLVED
Closed: 24 years ago
Resolution: --- → DUPLICATE
This seems like a different problem than the cases in bug 35681. Could someone 
verify that this is a duplicate?
I don't think its a duplicate-at least of that one.  This bug is just saying that 
there should be a redraw involved here.  Not that there is a *problem* (of which 
there are a few) with larger fonts.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Marking NEW so someone can make a decision on whether or not we should have a
redraw happening.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Netscape 4.x redraws on a text size change. Adding 4xp.
Keywords: 4xp
I just tried this (linux trunk build 2000110908) and I get a redraw and reflow
when I increase the font size.

Are people still seeing this problem?
It redraws but causes some text and widget size mishaps and confusion.  See
attachment. I think it is partly caused by the new messages the browser sends to
draw all those native GTK widgets. Doesn't seem to be a problem on xp widgets.
Changing summary. So this should work on most pages now. Yay!

Workaround: Reload.

Can anyone confirm this on a platform other than linux?

Running linux 20001107 build (where is the build number now?) on Red Hat 7.0.
Summary: Text resize should force redraw → Redraw on text resize causes text and widget size problems
Attached image Screenshot of confusion
At least part of this bug is covered by bug 47275.
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok
I suggest marking this worksforme, since the problem is hardly seen (you have to
try hard to get it), and no one seems to be attempting to fix it.
If nobody is currently working to fix a bug does not mean it is worksforme,
regardless of how difficult the bug is to reproduce (if it can be reproduced).
Ok, disregard my last comment now, I just got it to do something like it again.
(In addition, I'm also experiencing a bug for which every character I type in
this box, it sends a "next page" signal and I can't see what the heck I'm typing...)

Steps to reproduce:
Go to the top of this bug report, or any other one for that matter.

Change your text size to 200%. The text inside the widgets gets
bigger, but the widgets themselves do not get larger. (Weird, because bug 47275
seems to describe the opposite behavior.) The drop-boxes also appear in a shade
of grey instead of my normal lavender (from my GTK theme).

In addition, GTK widgets like the cc: box do not resize, text or font.

Now, change your size back to 100%. Yay, back to normal. Although the drop boxes
are still grey.

I know that worksforme is supposed to be for something that can't be reproduced
at all, and I thought that it couldn't be. Sorry for the spam.
Well this sounds like a layout issue of some sort.  The main problem described 
at the botton is that all the text on the page resizes when the text size is 
changed but the widgets are not resized to accomodate the larger text.  Not sure 
who's in charge or laying out widgets on the page but I'll start at layout.
Assignee: joki → karnaze
Component: Event Handling → Layout
QA Contact: gerardok → petersen
Two problems now remain:

1) Text resize causes the text inside XP widgets to resize, but not the text
inside the widgets.

2) GTK native widgets do not change size, and the text inside them does not
change size either. Note that if a native widget in question is off the screen
when the resize occurs, you can scroll up to it after the resize and see that
the font is correct.

I'm going to spin off these two problems into new bugs, and mark this one fixed
because the original problem from this bug (no reflow on text resize) was fixed.
Status: NEW → RESOLVED
Closed: 24 years ago24 years ago
Resolution: --- → FIXED
Summary: Redraw on text resize causes text and widget size problems → No reflow on text resize
Status: RESOLVED → VERIFIED
Marking verified per last comments.
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: