Saved tab browsers at exit does not reappear after restarting firefox

RESOLVED INVALID

Status

()

Firefox
Session Restore
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Wayne, Unassigned)

Tracking

3.5 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: 3.5.2

At closing Firefox, a box appears with option asking if I want Firefox to save my tabs for next time starting?  I click on the "Save and Quit" button, but at restarting Firefox, the tabs do not appear and the Yahoo web page shows up as a default.  This has only begun since loading the new upgrade 3.5.2 version of Firefox.  Because of this inconvenience, I have had to reinstall the prior version 3.0.13 until this is resolved.

Reproducible: Always

Steps to Reproduce:
1.Klick on Quit Firefox
2.Box appears with the option of saving tabs
3.Click on button "Save and Quit"
4.Firefox closes
5..Open Firefox application
6.Firefox opens with the "saved" tabs not being present and Yahoo appearing as a defualt web page.
Actual Results:  
Same results

Expected Results:  
Upon restarting Firefox, the saved tabs should be there.

Updated

8 years ago
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore
Version: unspecified → 3.5 Branch

Comment 1

8 years ago
Can you say what "Firefox will" is set to in the "History" part of your "Privacy" section in Firefox settings?
If it's set to "Never Remember History" then that includes the history in the tabs you wanted to save.
Same thing if it's set to "Use custom settings for history" and you click the "Settings" button and see "Browsing History" ticked.
If you have either of the above I think the box with option of saving tabs should not appear. It is a bug if it does without overriding those settings.
(Reporter)

Comment 2

8 years ago
Your guidance helped.  I unchecked the clear "browsing history" button at closing.  The tabs are now being saved, and reappearing at restarting Firefox.  Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
OK, INVALID as this is not a bug.
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.