If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox hangs when attempting to scroll a very large table

RESOLVED DUPLICATE of bug 477564

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 477564
8 years ago
8 years ago

People

(Reporter: Paul Levin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

I have a web site that generates a very large table (over 2000 rows).  When loaded, Firefox says its done, but when I try to scroll down, Firefox hangs.  Looking in Task Manager I can see the memory usage go up (from 110K to 160K and then jump back down to 110K and repeat).  This cycling of memory usage continues forever (or a very long time).  The browser is non-responsive and can not be terminated with the window close (the X button).  I have to kill it from Task Manager.  I saved the large page to a file, and it is 2.2 MByte.

By the way, I accessed the same large table with Microsoft Explorer and it loaded and functioned normally.  So the issue is not with the web page, but with Firefox.

Reproducible: Always

Steps to Reproduce:
Since my web site is private, you can not access the table I'm generating, but I can email for ftp the saved file to you.  Loading this file in Firefox results in the same hanging as accessing the web site.
Actual Results:  
Firefox is non-responsive and must be killed from task manager.


Expected Results:  
the page should scroll normally

contact me and I can send you the saved file of the web page.

Comment 1

8 years ago
Just attatch it to this bug. Does it have any form input elements on it? If so it might be a duplicate of bug 477564
(Reporter)

Comment 2

8 years ago
Yes there is a form, but there are no inputs in the table itself.  I will attach the file.
(Reporter)

Comment 3

8 years ago
Created attachment 396002 [details]
the very large table that causes FF to hang when attempting to scroll down

NOTE that the attachment is a zip of the htm file being submitted.
Use the file to reproduce the bug.  Just open the file from FireFox, and after FF says "Done" in the status bar, attempt to scroll down.

Comment 4

8 years ago
Every table row on that page has an <input type="checkbox"> on it, and this doesn't hang on trunk, duping.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477564
(Reporter)

Comment 5

8 years ago
Oops, you are correct - every row has a checkbox field.  My mistake.
I see that the fix for this bug will be in 1.9.1.3, and that the current official release is 1.9.1.2.  Any idea when 1.9.1.3 will be released?
Thanks.
You need to log in before you can comment on or make changes to this bug.