Cannot paste tabular data from a web page into Excel since loading 3.5.2

RESOLVED DUPLICATE of bug 137450

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 137450
9 years ago
9 years ago

People

(Reporter: John, Unassigned)

Tracking

3.5 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

In the past, I have been able to copy and paste data directly TO any of my spreadsheets FROM tables on web pages using Firefox without a problem.

Now, since upgrade to FireFox 3.5.2, I cannot do so. When I try, I get the Excel drop down message, " Microsoft Excel cannot paste the data".

I can paste the data into MS Word first, and then copy that and paste to Excel, but nothing directly from web pages using Firefox. I can also drag the data to my desktop as a text clipping and then paste into Excel without a problem.

I can do a work-around by going to the Excel EDIT menu and selecting Paste Special, which shows the paste as HTML. I then can change the "AS" to "Uninicode Text" or "Text" and it works just fine. However, it always defaults back to "HTML" and will not paste into my spreadsheets without going through the Paste Special routine.

THIS IS NOT A PROBLEM WHEN COPYING FROM SAFARI.

Using Office 2004 for Mac (Excel 11.3.4) on a Mac G4 runing 10.4.11.
Thanks in advance. 

Reproducible: Always

Steps to Reproduce:
1.Copy data from any webpage
2.Paste to an Excel spreadsheet

Actual Results:  
Nothing happens, except that I get Excel message, " Microsoft Excel cannot paste the data".


Expected Results:  
It should have pasted the date in to the spreadsheet, as all other version or Firefox have done.

II can do a work-around by going to the Excel EDIT menu and selecting Paste Special, which shows the paste as HTML. I then can change the "AS" to "Uninicode Text" or "Text" and it works just fine. However, it always defaults back to "HTML" and will not paste into my spreadsheets without going through the Paste Special routine.

THIS IS NOT A PROBLEM WHEN COPYING FROM SAFARI.
Component: General → General
Product: Thunderbird → Firefox
QA Contact: general → general
Version: unspecified → 3.5 Branch

Comment 1

9 years ago
see bug 470384 comment 13 for rational of duping to such an old bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 137450
You need to log in before you can comment on or make changes to this bug.