Table with border radius, when dynamically resized, does not redraw border

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: billy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

When the height of the table changes (for example, an AJAX call to fill it), the rounded border from before the resize stays in its position.  Therefore, you see a rounded corner floating in the middle of the table border (link goes to photo).

It disappears if anything forces a redraw (such as scrolling, or switching tabs)

Reproducible: Always

Steps to Reproduce:
1. Create a table with a border radius
2. Fill the table with something that resizes the height

Actual Results:  
Corner remnant doesn't disappear

Expected Results:  
Corner should disappear and be shown only on the bottom of the table
Could you attach HTML showing the bug or point to a URL that shows the problem?
Created attachment 419747 [details]
a testcase that doesn't show the problem

This table resizes when the user hovers over it, and it repaints just fine.
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
And the Reflow methods in nsTableFrame, nsTableRowGroupFrame, nsTableRowFrame, and nsTableCellFrame all seem to call CheckInvalidateSizeChange just fine.
Marking as WORKSFORME due to lack of an HTML example or URL; please reopen if one is provided.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.