Closed Bug 512102 Opened 11 years ago Closed 11 years ago

build bustage: trailing commas in enums

Categories

(NSS :: Libraries, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 507482

People

(Reporter: ul-mcamafia, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.8.1.22) Gecko/20090605 SeaMonkey/1.1.17
Build Identifier: THUNDERBIRD 2.0.0.23

trailing commas after last element in enums in
cmd/lib/pk11table.h ,v 1.7
lib/libpkix/include/pkixt.h ,v1.16
lib/softoknt.h ,v1.5

Reproducible: Always

Steps to Reproduce:
1. Compile with Visual Age 6 on AIX
2.
3.
Actual Results:  
Compile error due to illegal C89 code
No errors with previous version up the Thunderbird 2.0.0.22 or Seamonkey 1.1.17

Expected Results:  
successful compilation without relying on documented compiler bugs
OS: Other → All
Hardware: PowerPC → All
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 507482
You need to log in before you can comment on or make changes to this bug.