Article that 404s - cannot be found - is listed on the Article List page

VERIFIED INVALID

Status

support.mozilla.org
General
VERIFIED INVALID
8 years ago
8 years ago

People

(Reporter: stephend, Assigned: paulc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Summary: Article that 404s - cannot be found - is listed on the Article List page

STR:

1. Load http://support-stage.mozilla.org/en-US/kb/Article+list
2. Either run a link checker on it or just click on the "Using the Quicktime Plugin with Firefox" article

Expected:

Page loads with its content (this page shouldn't be indexed)

Actual:

Page cannot be found (404)

Comment 1

8 years ago
It is there, as http://support-stage.mozilla.org/en-US/kb/Using+the+QuickTime-plugin+with+Firefox  (notice the - ) The page doesnt look like it updates when a article is renamed.
(Assignee)

Comment 2

8 years ago
Indeed, I also tried renaming a page and Article+List didn't update. We should make that bug about fixing this. It might have to do with the PAGELIST plugin.
(Assignee)

Updated

8 years ago
Assignee: nobody → paul.craciunoiu
PAGELIST probably gets its data from sumotools (which has the correct article name), not support-stage. I'm guessing this bug is invalid.
CCing Cheng.
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> PAGELIST probably gets its data from sumotools (which has the correct article
> name), not support-stage. I'm guessing this bug is invalid.
> CCing Cheng.

If that's the case, can we please fix that?  It causes churn to have invalid bugs due to staging problems.

Comment 5

8 years ago
What's happening is the script that was doing this was erroring out on tools (someone changed permissions on a file).  Should be fixed now.

Also FWIW, the pagelist plugin gets updates once a week because it uses data from omniture that I import manually on that schedule.
(Assignee)

Comment 6

8 years ago
Sounds fixed. Not sure if this should go under any milestone.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

8 years ago
Well, http://support-stage.mozilla.org/en-US/kb/OCSP+error+when+accessing+secure+sites and http://support-stage.mozilla.org/en-US/kb/Window+shakes are still listed, and are 404s.

(Link checkers FTW.)
This sounds more like a 'cantfix', if that resolution was available. :-)

AIUI, the problem is that the list is based on omniture data, which doesn't apply to stage.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

8 years ago
check on prod.... the prod version at least updates automatically.
(Reporter)

Comment 10

8 years ago
http://validator.w3.org/checklink?uri=http%3A%2F%2Fsupport.mozilla.com%2Fen-US%2Fkb%2FArticle%2Blist&hide_type=all&depth=&check=Check reveals no broken links on prod.

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 11

8 years ago
Verified invalid.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.