Closed Bug 512149 Opened 11 years ago Closed 10 years ago

message body missing from local offline store - "The body of this message has not been downloaded"

Categories

(MailNews Core :: Backend, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: wsmwk, Unassigned)

References

Details

I lost connectivity with my mail server this morning, and discovered that all the messages for which I have headers from overnight (bugmail - a period of about 10 hours) don't have message bodies. The imap account is set that all folders should be stored locally. going offline did not make a difference.  I do have message bodies for those messages in that period for which I clicked the message prior to my connectivity outage.  Gloda indexing is enabled.

I can't say 100% sure this is a regression, but I've never encountered this problem before.

message is "The body of this message has not been downloaded from the server for reading offline."

20090822 Shredder/3.0b4pre
(In reply to comment #0)
> going offline did not make a difference. 

to clarify, "did not make a difference"... in whether it could display the message. But I had not permitted download sync when I responded to the "going offline" dialog.
I suppose nothing was present in the event log ? Can you create logs, when you try to synch ?

Is it more than one folder ? If so what happens if you delete the .msf for one of the folders ? Do you get the complete emails afterwards ?
(In reply to comment #2)
> I suppose nothing was present in the event log ? Can you create logs, when you
> try to synch ?

nothing was in event log.

> Is it more than one folder ? If so what happens if you delete the .msf for one
> of the folders ? Do you get the complete emails afterwards ?

Definitely affected the folder my bugmail filters too.
I think it also affected the inbox.
Didn't save the profile, so not able to go back and check about .msf.
I got complete email after, iirc, going back online.
Sounds likely bug 468595 would fix
No longer blocks: 468595
Depends on: 468595
Bug 468595 is already fixed. (See Bug 468595 Comment #55 for checkin id)
Can you reproduce your problem with newest trunk nightly build?
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1-l10n/
> If MS Win, download win32.zip build. You can test by UNZIP only.
(In reply to comment #5)
> Bug 468595 is already fixed. (See Bug 468595 Comment #55 for checkin id)
> Can you reproduce your problem with newest trunk nightly build?
> > http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/
> > http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1-l10n/
> > If MS Win, download win32.zip build. You can test by UNZIP only.

rereading this, I don't know why this happened nor do I know how to recreate it, so for me there is clear relationship to Bug 468595. The skeptic in me says leave this open, but the pessimist says I'll never see this again. Therefore, closing incomplete.  (I'll have logging on for the next time it happens)
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.