Clear Recent History clears cookie exception list

VERIFIED INVALID

Status

()

Firefox
Private Browsing
--
major
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Christopher Kenna, Unassigned)

Tracking

3.5 Branch
x86_64
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

When doing a Tools -> Clear Recent History and selecting Everything, Firefox also clears out the list of sites that I have added to exceptions in my "accept cookies from list."  Older versions of Firefox (the 3.0 series) did not do this.  It is annoying because I want to clear the cookies set by those sites, but not remove those sites as exceptions.

Reproducible: Always

Steps to Reproduce:
1. Tools -> Options -> Privacy uncheck "Accept cookies from sites"
2. Click Exceptions, add one or more sites to list.  Confirm/Close all open dialogs.
3. Tools -> Clear Recent History -> Everything -> Clear Now
4. Observe as the Exceptions list just created is clear.
Actual Results:  
Removed my exceptions.

Expected Results:  
Keep exceptions, but delete the cookies.

Comment 1

9 years ago
Is this the expected behavior?
Version: unspecified → 3.5 Branch

Comment 2

9 years ago
I'm not able to reproduce, Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3pre) Gecko/20090821 Shiretoko/3.5.3pre.

Reporter, can you try in safe mode with all add-ons disabled?

The Everything option in 3.5 hands off to nsICookieManager.removeAll(), which is what 3.0 does.  Looking at the code I don't immediately see any significant difference between 3.0 and 3.5, unless there is a new cookie-changed observer somewhere.
(Reporter)

Comment 3

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

Upgraded to 3.5.2 and tried in safe mode and the same thing happens.
(Reporter)

Comment 4

9 years ago
I hammered it down to the "Site Preferences" check box.  Checking this box in the clear recent history dialog results in the exception list getting deleted.  I'll avoid checking this box in the future.  If this is the expected behavior, sorry to bother, close this.
-> RESOLVED - working as designed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.