javascript after IFrame not execting

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: jon.hopkins, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

javascript not executing after an iframe but ok before.

Reproducible: Always

Steps to Reproduce:
<!doctype html public '-//IETF//DTD HTML 2.0//EN'>

<html>
<head>
<meta name='Generator' content='WebStar 1.0'>
<title></title>
</head>
<body>
<script>
alert('jon');
</script>

<iframe src="http://www.mozilla.org" height=200 width=200></frame>

<script>
alert('jon2');
</script>
</body>
</html>
Actual Results:  
only first alert executes

Expected Results:  
both should run
Wrong close tag you have written </frame> rather than </iframe>
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
<iframe src="http://www.mozilla.org" height=200 width=200 />

however stops further javascript execution.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
That's invalid too. Either serve the page as XHTML or don't use XHTML-only syntax.
(See XHTML 1.0 Appendix C for some guidelines on "backwards-compatibility").
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.