marking as "not junk" doesn't reload to show unsanitized view

RESOLVED FIXED in Thunderbird 3.0b4

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Magnus Melin, Assigned: Magnus Melin)

Tracking

({regression})

Trunk
Thunderbird 3.0b4
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

4.32 KB, patch
Bienvenu
: review+
Details | Diff | Splinter Review
(Assignee)

Description

9 years ago
Created attachment 396251 [details] [diff] [review]
proposed fix

If you have an html message wrongfully marked as junk and mark it "not junk", it should reload to show the full html instead of the simple html version.

Regression from bug 462681. (var isJunk = (junkScore == "") || (junkScore == "0") is wrong.)
Attachment #396251 - Flags: review?(bugzilla)
Comment on attachment 396251 [details] [diff] [review]
proposed fix

+      let wontMoveToJunk = (folder.server.spamSettings.manualMark !=
+        Components.interfaces.nsISpamSettings.MANUAL_MARK_MODE_MOVE) ||
+        folder.isSpecialFolder(Components.interfaces.nsMsgFolderFlags.Junk);

This appears to be the wrong sense - I've tested a message on local folders and on pop and when I've disabled the preference to move to the account's junk folder, then wontMoveToJunk is false.
Attachment #396251 - Flags: review?(bugzilla) → review-
(Assignee)

Updated

9 years ago
Duplicate of this bug: 510595

Comment 3

9 years ago
This also leads to situations where we get messages half-loaded in the message pane, so I think it would be very good to fix this for TB 3.
(Assignee)

Comment 4

9 years ago
Created attachment 398673 [details] [diff] [review]
proposed fix, v2

As we're nowadays always moving junk back to inbox, an additional check was needed. (Also i messed up manualMark vs manualMarkMode earlier. Added doc to make it clearer in the future.)

The one edge case this doesn't reload where it could be useful is with mark-as-deleted, for the last message in view, but but...
Attachment #396251 - Attachment is obsolete: true
Attachment #398673 - Flags: review?(bienvenu)

Comment 5

9 years ago
Comment on attachment 398673 [details] [diff] [review]
proposed fix, v2

looks good, thx
Attachment #398673 - Flags: review?(bienvenu) → review+
(Assignee)

Comment 6

9 years ago
changeset:   3532:310086e2a1d1
http://hg.mozilla.org/comm-central/rev/310086e2a1d1

->FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.