URL Bar blocks input while it loads the list of suggestions

RESOLVED DUPLICATE of bug 455555

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 455555
9 years ago
9 years ago

People

(Reporter: domonoky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

If you freshly start the Browser and begin to enter a URL, Firefox will block any input in the URL-Bar after the first character typed until it has loaded the list of suggestions. 

This is very uncomfortable as this can take some seconds and you cant type while it loads.
This loading of the suggestion list should happen in the background.


Reproducible: Always

Steps to Reproduce:
1. Open Browser
2. Start typing a URL in the URL bar (something like www.bugzilla.mozilla.org)

Actual Results:  
You will see the input of characters stop until the list of suggestions are loaded.

Expected Results:  
You should be able to continue typing while it loads the list of suggestions.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 455555
You need to log in before you can comment on or make changes to this bug.