If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<radio> elemens inside a <radiogroup> and child don't unless inside a <titledbox>

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
major
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Charles Manske, Assigned: David Hyatt)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Radio buttons don't display at all if placed inside a <radiogroup> unless
they are also inside a <tiledbox> ...</titledbox>
I've tried other containers, such as simple a <box>, but nothing seems to work.
This seems to be an unnecessary restriction to the use of radiogroup.
I will attach a test case the demonstrates the problem when loaded in Navigator.
(Reporter)

Comment 1

17 years ago
Created attachment 13969 [details]
radio buttons inside a radiogroup don't display if not in titledbox
(Reporter)

Comment 2

17 years ago
Not sure if this is a XUL problem or maybe a side effect of XBL or CSS,
so cc'ing ben and hyatt.

Comment 3

17 years ago
For me, the testcase displays radio's in either case (inside or outside a 
titledbox) using the 2000090308 mac/linux/win32 verif. builds.

(However, there have been other reports of transient problems with the UI over
the weekend, which subsequently just started working again for the reporter.)
(Assignee)

Comment 4

17 years ago
Can't reproduce this...
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

17 years ago
This bug exists, but only when the "Disable XUL cache" debug preference is set!
Also, it apparently is a bug only with the Modern and Blue skins.
So I understand if it's not a priority to fix, but it does make debugging
XUL dialogs more difficult.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 6

17 years ago
->future.  Yet another reason to use the Classic skin.
Target Milestone: --- → Future

Comment 7

17 years ago
Looks like a skin or xbl bug. There is no difference between a titlebox and a 
box. Except a titled box has a few anonymous boxes inside.
Assignee: evaughan → hyatt
Status: REOPENED → NEW

Comment 8

16 years ago
Worksforme (although the labels are not displayed due to syntax change)
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.