crash with unbalanced <ul> and <li> tags with <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0//EN">

VERIFIED DUPLICATE of bug 50994

Status

()

Core
HTML: Parser
P3
critical
VERIFIED DUPLICATE of bug 50994
18 years ago
18 years ago

People

(Reporter: yashi, Assigned: rickg)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17pre11 i586; en-US; m18) Gecko/20000902
BuildID:    0000000000

I assume summary says it all. but,changing doctype to <!doctype html PUBLIC
"-//W3C//DTD HTML 4.01 Transitional//EN"> doesn't kill it.

Reproducible: Always
Steps to Reproduce:
1.just open the url
2.it dies
3.

Expected Results:

Comment 1

18 years ago
This is happening on the 2000090308 build. I'm experiencing the same problem, 
but on Windows. This bug should get the keyword 
regression, since this problem didn't exist in previous builds.

I tested the problem with different cases and can confirm for sure that the 
problem is due to the missing </li>

Following code will cause the crash if Doctype is set to strict.

<ul>
   <li>text
</ul>

It is valid HTML 4 strict, since the W3C Reference says closing LI-tag to be 
optional.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
Duplicate

*** This bug has been marked as a duplicate of 50994 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
This is a dup of bug 50994:Crashing in nsCParserNode::GetNodeType, with strict
DOCTYPE and unclosed tags
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.