spell checker doesn't accept plurals "analyses", "catalyses", "paralyses"

RESOLVED DUPLICATE of bug 499593

Status

()

Core
Spelling checker
RESOLVED DUPLICATE of bug 499593
8 years ago
8 years ago

People

(Reporter: skierpage, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a1pre) Gecko/20090823 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a1pre) Gecko/20090823 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20090823034121

"analyses" is definitely the plural of "analysis" -- http://www.merriam-webster.com/dictionary/analyses , but Firefox 3.7 and Thunderbird 3 don't accept it.  Nor do they accept the plurals "catalyses" and "paralyses".  It looks like the plural form has been manually added to en-US.dic for other words ending in "sis" such as "antitheses","nemeses", "theses", etc.

Reproducible: Always

Steps to Reproduce:
1.  Paste the words above into a text field.

Actual Results:  
FF and TB flag valid plurals are spelling mistakes.

Expected Results:  
Match other dictionaries like m-w.com or dictionary.reference.com.

I dunno if the pluralization of words ending "is" as "es" is a reliable or common enough rule to deserve a SFX rule in en-US.aff.

Comment 1

8 years ago
please add comments to bug 499593 - we can't have a separate bug ticket for every word
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499593

Comment 2

8 years ago
I suspect the reason these three were left out is because they are the third person of the verb form in British English -- i.e. he analyses, she catalyses, etc.

In any case, they're all valid as plural nouns and should be included, especially analyses which is quite common.
You need to log in before you can comment on or make changes to this bug.