Preference under Browser "Display On" are not retained

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Wade Reese, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Halloween2011Bug])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3pre) Gecko/20090823 SeaMonkey/2.0b2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3pre) Gecko/20090823 SeaMonkey/2.0b2pre

If I set SM preference, "Display On" to New Window -> Home Page, SM will not remember that setting.  I will only get blank pages (not home page) if I close a SM browser window and then reopen SM from the Dock.  It will never open back up in my Home Page.  The only way I can get that to happen is to totally shut down SM and restart it.  Then the Home Page will be displayed in the newly opened browser window.

Reproducible: Always

Steps to Reproduce:
1.Set SM preferences "Display On" to New Window -> Home Page 
2.Close SM window (but leave SM open in the Dock)
3.Reopen SM from the Dock... and you get just a blank browser page (not the Home Page).
Actual Results:  
Get a blank page (and not the Home Page)

Expected Results:  
Reopen a SM page that displays my preselected Home Page.

Comment 1

9 years ago
Wade,

Can you go to about:config (type 'about:config' in the address field, then hit Enter), then check what the preference 'browser.windows.loadOnNewWindow' (you can just paste it in the filter field and it'll show up) is set to?

Btw, this works for me with my own trunk build (recent source).
(Reporter)

Comment 2

9 years ago
here you go...

browser.windows.loadOnNewWindow;1

Comment 3

9 years ago
Hmm... What are your settings for "Display On Browser Startup"? I can reproduce this if I have my Browser startup pref set to open a blank window. In other words, this indicates that the bug here is that the preference thinks that you have quit seamonkey when you closed all opened windows.
(Reporter)

Comment 4

9 years ago
Display on Browser Startup is set to "Home Page".  So is Window and Tab.

I did notice that after the SM auto update that I got yesterday, this issue seems to be resolved.  Interesting.
(Reporter)

Comment 5

9 years ago
UPDATE as of 9/2/09

I just installed Snow Leopard and the problem described above is back.  On SM, I am on build 20090831004626.

Bummer.
Version: unspecified → Trunk

Comment 6

9 years ago
I am seeing this bug too. I noticed that if I have no windows open and then open two windows, the first one has a blank page, and second one has my file:/// url page as the startup page. Also, when I start up my browser, the first window has my home page as the startup page.

The preference is being retained (I had a bit of confusion at first about the user interface for this setting), but it is not being honored when a first window is opened.

Seamonkey 2.0 release version
OS X 10.4.11 x86
browser.startup.page;1
browser.windows.loadOnNewWindow;1

Also, I just installed it on a PPC running 10.4.11 which had been previously running SeaMonkey 1.1.3, and the bug did NOT happen.

Comment 7

9 years ago
So, if you close all windows the startup preference should not be honored when opening a new window - instead the New Window pref should be honored. OTOH, quitting seamonkey and re-start should honor the startup pref.

Comment 8

7 years ago
WORKSFORME
browser.startup.page;1
browser.windows.loadOnNewWindow;1
No matter how I trying, home page is always loading...
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111017 Firefox/10.0a1 SeaMonkey/2.7a1

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [Halloween2011Bug]
You need to log in before you can comment on or make changes to this bug.