jpgs not saving correctly when using "save image as"

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
major
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: ozarkmtndd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR3.5.30729) 

With the cursor on a jpg and you right click the option "save image as" the file size that is saved is 1k.  It saves a placeholder jpg icon but the not the image.  If you save from the thumbnail it saves correctly and includes the full size of the file. This sometimes happens on imbedded jpgs on web pages as well.
Everything looks normal as it gives you the option to "save image as" but when you go back and check it has saved a place holder "jpg" icon but the file size is only 1k.

Reproducible: Always

Steps to Reproduce:
1.click on thumbnail and load image
2.right click image and save as
3.image saved 
Actual Results:  
actual size of the image that is saved is only 1k.  looks like it save til you try to open image.  saves an icon that looks like a jpg but does not open.

Expected Results:  
should saved the image regardless of being a thumbnail or actual image if it gives you the option to save as a jpg. 

i have had this happen both on single images that i have clicked on from thumbnails and actual imbedded images in web pages. These are not protected images because it gives me the option to save them.  It looks as though it did save as the image has a jpg icon but the file size is incorrect. should be 316k and its only 1k.  1k= no image saved.  default theme used.
(Reporter)

Comment 1

9 years ago
i tested the image in another browser (IE) and it save correctly.

Comment 2

8 years ago
"1.click on thumbnail and load image"

What thumbnail? 
Can you give an URL that causes the problem?

Sounds to me as if you encountered a web page that "hides" images as background images instead of normal images, to avoid having people saving them.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.