Layout and css of Mint.com is broken on trunk and 1.9.2 branch

VERIFIED FIXED in mozilla1.9.3a1

Status

()

Core
Layout
P2
normal
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: tchung, Assigned: dbaron)

Tracking

(Depends on: 1 bug, {verified1.9.2})

Trunk
mozilla1.9.3a1
verified1.9.2
Points:
---
Bug Flags:
blocking1.9.2 +

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
The layout and css of Mint.com is completely broken on Namoroka.  If you compare it side by side to shiretoko branch, you can see the following differences:
- Tabs are mirating to the bottom right.  ("Features", "Why use mint", "Ways to Save", etc..  also "Understand your Money", "All your accounts...", "Easy")
- scroll down, and the green background is lighter than shiretoko.
- If you log in, there is missing form areas (eg. change your address)

Namoroka screenshot: 
1) http://www.grabup.com/uploads/a38852d2bab2ef0a337a2c48ebc65d32.png
Shiretoko screenshot:
1) http://www.grabup.com/uploads/631ca1d2413cf1e71ff8c4216748d70b.png

Namoroka screenshot:
2) http://www.grabup.com/uploads/6be27793297751536859fb98b0ecb994.png
Shiretoko screenshot:
2) http://www.grabup.com/uploads/4460299351de89a743e60219615f5929.png

Tested on: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a2pre) Gecko/20090825 Namoroka/3.6a2pre
(Reporter)

Comment 1

9 years ago
Here's a screenshot of the missing formfield on namaroka.

Namaroka: 
- http://www.grabup.com/uploads/5748df880ad0ca0b1316b02849831853.png
Shiretoko: 
- http://www.grabup.com/uploads/ac3be1325b72d821706018aeae920718.png
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090825 Minefield/3.7a1pre

Also broken on Windows.
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 3

9 years ago
affects trunk builds as well.
Summary: Layout and css of Mint.com is broken on 1.9.2 branch → Layout and css of Mint.com is broken on trunk and 1.9.2 branch
Version: 1.9.2 Branch → Trunk
(Reporter)

Comment 4

9 years ago
Regression range:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bc6ffc794fc1&tochange=bf206df7eff9

The darker green background, and the missing formfield seem to be another issue altogether.   Likely a separate bug here, since the regression for those areas dont match up.
Keywords: regression

Comment 5

9 years ago
I don't see the issue with the darker background-color (OS X 10.5.8).

The issue with the link blocks that display as a staircase is likely this:
311576cc5f51	L. David Baron — Make lines with only a bullet take up height. (Bug 179596 / Bug 507187) r=roc

cc'ing Dbaron

Comment 6

9 years ago
Created attachment 396695 [details]
minimized test case

The blocks of links that display as a staircase is an unordered list with 
list-style:none; containing links set to float left. The list-items (li) are unstyled.
(Assignee)

Comment 7

9 years ago
I suppose we could make Has[Outside]Bullet return false when 'list-style-type' and 'list-style-image' are 'none', even if 'display' is 'list-item'.

Do other browsers have the same behavior when the 'list-style: none' is removed?  I'd hope they do.
(Assignee)

Updated

9 years ago
Flags: blocking1.9.2?

Comment 8

9 years ago
Created attachment 396932 [details]
screenshot

(In reply to comment #7)
 
> Do other browsers have the same behavior when the 'list-style: none' is
> removed?  I'd hope they do.

The screenshot tells the whole story I hope. Same testcase, without the list-style:none. Browsers don't agree about the position of the list-marker.

Background is IE 8, Win 7RC in a VM. Foreground: top-right is Minefield, bottom-left is WebKit latest, bottom-right is Opera 10rc.
(Assignee)

Comment 9

9 years ago
Well, that at least shows that the right fix for this bug is to condition the code that caused the regression on the condition in comment 7.
(Assignee)

Updated

9 years ago
Assignee: nobody → dbaron
(Assignee)

Comment 10

9 years ago
Created attachment 399508 [details] [diff] [review]
patch

This conditions the recently-added code on the bullet being non-empty.
Attachment #399508 - Flags: review?(roc)
Flags: blocking1.9.2? → blocking1.9.2+
Priority: -- → P2
(Assignee)

Comment 11

9 years ago
http://hg.mozilla.org/mozilla-central/rev/3d331523f2ad
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1

Updated

9 years ago
Depends on: 516105
(Reporter)

Comment 13

9 years ago
Verified fix on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a2pre) Gecko/20090918 Namoroka/3.6a2pre
and Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090918 Shiretoko/3.5.4pre
Status: RESOLVED → VERIFIED
Keywords: regression → verified1.9.2
You need to log in before you can comment on or make changes to this bug.