Page is shown as loading (nsILoadGroup::isPending is always true)

RESOLVED DUPLICATE of bug 81980

Status

()

defect
RESOLVED DUPLICATE of bug 81980
10 years ago
10 years ago

People

(Reporter: gerald_leder, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

When you click in the "Click here" button on the attached html page (see next comment - isPending.html) which writes a document 
<input type="button" value="Click here" onClick="document.write('<div>Hello world !</div>');">
but the browser never finish loading it. You see the loading symbol in the tab spinning and the progressbar all the time (until you press the stop button). 

The nsILoadGroup::isPending is also not updated correctly which is not good because I have an extension which uses this to check if the page is finished loading but this returns always true.

This problem is in FF2.x, FF3.x and FF3.5.

Reproducible: Always

Steps to Reproduce:
1. Open the attached html page isPending.html
2. Click either on "Click here" from Test 1 or Test 2
3. Document is changed but page seems to be loaded


Actual Results:  
Page loading symbol in the tab and progress bar is shown as the document is always loaded.
nsILoadGroup::isPending is always true

Expected Results:  
Loading symbol in the should not be spinning and no progessbar should be shown.
nsILoadGroup::isPending should be false.

When loading the document from the cache page is correctly loaded and document loading is not shown. 
1. Open the attached html page isPending.html
2. Click either on "Click here" from Test 1 or Test 2
3. Document is written
4. Click on the home button
5. Click on the back button - no loading symbols are shown
(Reporter)

Comment 1

10 years ago
There are two test cases for reproducing the problem. Both changes with document.write the page content.

Test 1 uses a button <input type="button" value="Click here" onClick="document.write('<div>Hello world !</div>');">

Test 2 generates a table with the help of a javascript. Click on the "here" link.

Please see the loading symbol in the tab and the progressbar after clicking on one of the test cases.

Comment 2

10 years ago
There is no document.close() so the browser doesn't know that you have finished writing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 81980
You need to log in before you can comment on or make changes to this bug.