Firefox will keep you unemployed in Sweden

VERIFIED INVALID

Status

()

VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: micko, Unassigned)

Tracking

3.5 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [caused by Ad Block+], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; sv-SE; rv:1.9.1.2) Gecko/20090803 Fedora/3.5.2-2.fc11 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; sv-SE; rv:1.9.1.2) Gecko/20090803 Fedora/3.5.2-2.fc11 Firefox/3.5.2

Visiting the Swedish employment service Firefox does not show advertisement of jobs. I have no idea if its due to broken code on their website, but it works with Konqueror 4.3.00. It all works ok until you look at a certain job. The advertisement just isn't there.

Reproducible: Always

Steps to Reproduce:
1.Visit http://platsbanken.arbetsformedlingen.se/Standard/SokViaArbetsort/SokresultatViaArbetsort.aspx?q=s(ld(199)l(17)k(1781))a(20)sp(65)sr(1)c(36730FB8)&ps=

2.Try to read about a specific job
3.Nothing will show 
Actual Results:  
Visit http://platsbanken.arbetsformedlingen.se and look for a job somewhere in Sweden.


No luck searching for this bug. Can it really be?
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch
Can you give more detailed steps to reproduce?
(Reporter)

Comment 2

9 years ago
Its a bit hard to make a good instruction, but I'll try my best. Let me know if its hard to follow. (I know this becomes a bit hard since its in Swedish)

1.) Got to http://platsbanken.arbetsformedlingen.se/Standard/SokViaArbetsort/SokViaArbetsort.aspx

2.) Press any link, for instance "Blekinge län (81)" 
3.) Press link, for instance "Karlshamn (9)"
4.) Press link, "Alla yrken (9)"
5.) Now available jobs are shown, press any of them to learn more.

Now there should be a lot to read from the company offering a position. Nothing shows.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3pre) Gecko/20090817 Shiretoko/3.5.3pre

Good instructions, the second time, but I do get a full page:

Lärare - inriktning förskola, Ref nr 4 B/09

Karlshamns kommun, Utbildningsförvaltningen

Publicerad: 2009-08-25, Annons-ID: 1569556

Karlshamn (Kommuninformation), 1 plats
Sista ansökningsdag: 2009-09-06
Visstidsanställning, heltid med tillträde enligt överenskommelse dock längst t o m
2009-12-31. Tjänsten kan komma att förlängas.

Kvalifikationer:
Vi söker medarbetare som förutom rätt lärarbehörighet också har lätt att samarbeta med andra, kan ta egna initiativ och har vilja och förmåga att se varje barns möjligheter. Stor hänsyn tas till personlig lämplighet.

Etc. Also a second link works normally here.

I only tested this on Windows Vista; no Linux here.

Maybe you can try safe-mode, or a new profile:
http://support.mozilla.com/en-US/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
(Reporter)

Comment 4

9 years ago
Yes, I tried safe-mode and know I do get a full page. 

I've tried this page at 3 different Linux machines with the same result. (Two with FC11 x86_64 and 1 Suse 11.1 i586) Tell me if there is something else that you want me to test.
Created attachment 396815 [details]
Screenshot of Sweden job offer page

Some people might overlook that the link has a = sign at the end, it didn't get hyperlinked and breaks the url because it was missing. You end up at an invalid link page.

The corrected url: http://tinyurl.com/kt8jp6

Using 6/26 trunk nightly, I go to the page, click on one of the jobs, it looks good on my end.

Screenshot attached.
(Reporter)

Comment 6

9 years ago
Now I got it, its the ADBLOCK PLUS extension blocking this page. I'm sorry, it just didn't struck me it might be blocking this site. Its a national government agency with no commercial and it's tax founded. Sorry for any trouble. Keep up the good work you do with Firefox!
Great that it's solved! Resolving INVALID (= not a bug in Firefox).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You know the funny thing was, I suspected he had Adblock Plus, and that in some very weird way it was blocking the page content. Too bad I didn't write that in my original comment. :P

Oddly enough, I am using Adblock Plus, as shown in my screenshot's statusbar but I am using a outdated subscription list from Feb2009 & a old nightly. But it may have been a custom filter you added caused all this.
Filters from different locations are different too. Ad block, unfortunately, will often block ligit things, that are really not ads, but look like them to Ad block.
Severity: major → normal
Status: RESOLVED → VERIFIED
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Whiteboard: [caused by Ad Block+]
I believe this is not a extension compatibility issue; it appears to me that the add-on worked correctly but was wrongly configured, happens also sometimes to me that I unintentionally filter out too much. 
Compatibility component was once created for the cases that extensions were not yet ready for the next version, the extension authors then got a notification. I believe it is even not meant for broken extensions causing problems but maybe that has changed.
You need to log in before you can comment on or make changes to this bug.