Spell check in text area fails to trigger onchange event

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: Robert Boyd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

Using the spell check on a text area, it does not trigger the javascript onchange event. Enough said.

Reproducible: Always

Steps to Reproduce:
1.Load form with bad spelling
2.Correct spelling using firefox spell checker
3.Button that is enabled by change of form element is not enabled because onchange even is not called when spell checker updated form element
Actual Results:  
No onchange event trigger, no result other than spelling corrected as expected.

Expected Results:  
Called the onchange event when the spell checker altered the contents of the text area.

Comment 1

9 years ago
Can't reproduce with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20090827 Minefield/3.7a1pre

Remember that onchange() is only triggered after the textarea loses focus and the contents have changed.

If I correct a spelling using the spell checker, then blur the textarea (click somewhere else on the page), onchange is triggered.
Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Also, please consider using the most recent Firefox 4 beta build, your bug may be resolved there.
Whiteboard: [CLOSEME 2011-1-1]
The scenario is incorrect, it should be:
1.Load form with bad spelling
2.Correct spelling using firefox spell checker
3.Unfocus the element
4.Button that is enabled by change of form element is not enabled because
onchange even is not called when spell checker updated form element
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Whiteboard: [CLOSEME 2011-1-1]
You need to log in before you can comment on or make changes to this bug.