Last Comment Bug 51280 - FindNext always receives NULL Search context in webclient test window
: FindNext always receives NULL Search context in webclient test window
Status: VERIFIED FIXED
:
Product: Core Graveyard
Classification: Graveyard
Component: Java APIs to WebShell (show other bugs)
: Trunk
: x86 Windows NT
: P3 normal (vote)
: ---
Assigned To: Ashu Kulkarni
: geetha.vaidyanaathan
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-04 05:56 PDT by Oleg Khokhlov
Modified: 2012-04-09 22:27 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Proposed patch - diff -u EMWindow.java (1.79 KB, patch)
2000-09-11 13:54 PDT, Ashu Kulkarni
no flags Details | Diff | Splinter Review
tar.gz of modified patch file (5.21 KB, application/octet-stream)
2000-09-11 13:54 PDT, Ashu Kulkarni
no flags Details
Proposed patch - diff -u EMWindow.java (1.73 KB, patch)
2000-09-12 09:39 PDT, Ashu Kulkarni
no flags Details | Diff | Splinter Review

Description Oleg Khokhlov 2000-09-04 05:56:19 PDT
How to reproduce:

1. Run webclient test window and load any URL.
2. Find some string via Search->Find.
3. Close find dialog.
4. Try to find next string via Search->FindNext menu item.

  You will always receive the message: "NULL SearchContext received for 
FindNext".

It is because currentPage.resetFind() is invoked in file EMWindow.java in method 
dialogDismissed(Dialog d).	

May be it's better to make separate menu item for ResetFind?

Mozilla M16 and Webclient source from Sep 04,2000.

P.S. And also currentPage.resetFind() is in method dialogCancelled(Dialog d).
Comment 1 edburns 2000-09-04 17:40:23 PDT
reassign ashu.
Comment 2 Ashu Kulkarni 2000-09-11 09:07:37 PDT
This is part of the Test application code. There is no problem with the
underlying Webclient API code and as the Test code is only a sample for the
Webclient users to build upon, I would not treat this as a Webclient bug.

Nevertheless, I will fix this behavior in the EMWindow code such that it mimics
the actions of the Mozilla browser.

_accept.

_Ashu
Comment 3 Ashu Kulkarni 2000-09-11 13:54:05 PDT
Created attachment 14418 [details] [diff] [review]
Proposed patch - diff -u EMWindow.java
Comment 4 Ashu Kulkarni 2000-09-11 13:54:58 PDT
Created attachment 14420 [details]
tar.gz of modified patch file
Comment 5 edburns 2000-09-11 15:03:27 PDT
Comments on http://bugzilla.mozilla.org/showattachment.cgi?attach_id=14418 :

Ashu, I don't like commented out code.  Please remove the commented out code in 
the fix and re-format the impacted lines.  If you do that, I give r=,a= edburns.
Comment 6 Ashu Kulkarni 2000-09-12 09:39:22 PDT
Created attachment 14494 [details] [diff] [review]
Proposed patch - diff -u EMWindow.java
Comment 7 Ashu Kulkarni 2000-09-12 09:41:11 PDT
Made changes in EMWindow such that resetFind is called only when the "clear"
button is selected. This mimics the behavior of mozilla/Netscape 4.x and IE.
There is no separate ResetFind button.

_Ashu
Comment 8 Keyser Sose 2000-10-05 21:34:03 PDT
Works for Me
Platform: PC
OS: Windows 98
Mozilla Version: 2000100508

Marking as Verified

Note You need to log in before you can comment on or make changes to this bug.