sm-cesium01.mozilla.org not running firefox tests

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: rdoherty, Assigned: fox2mike)

Tracking

Details

(Reporter)

Description

8 years ago
I noticed that there are no recorded Firefox tests on sm-cesium01.mozilla.org, but Firefox & vnc have been setup and put into cron. And there are pages to test.

A few things could be going wrong:
* Spawning firefox is failing
* Yslow and/or firebug isn't installed
* cesium profile user.js is corrupted/missing (copy from cesium/install/user.js)
* the wrong profile is being loaded (should be cesium)
* Firefox can't display to the vnc display

easy way to test is to run `python manage.py cesiumcron` in DOCROOT/cesium
(Assignee)

Comment 1

8 years ago
Looking into this.
Assignee: server-ops → shyam
(Assignee)

Comment 2

8 years ago
(virtual_env)[cesium@sm-cesium01 cesium]$ python manage.py cesiumcron
Traceback (most recent call last):
  File "manage.py", line 12, in <module>
    execute_manager(settings)
  File "/opt/cesium/virtual_env/lib/python2.6/site-packages/django/core/management/__init__.py", line 362, in execute_manager
    utility.execute()
  File "/opt/cesium/virtual_env/lib/python2.6/site-packages/django/core/management/__init__.py", line 303, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/opt/cesium/virtual_env/lib/python2.6/site-packages/django/core/management/base.py", line 195, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/opt/cesium/virtual_env/lib/python2.6/site-packages/django/core/management/base.py", line 222, in execute
    output = self.handle(*args, **options)
  File "/opt/cesium/trunk/cesium/../cesium/autoyslow/management/commands/cesiumcron.py", line 18, in handle
    for site in self.get_sites_to_test():
  File "/opt/cesium/trunk/cesium/../cesium/autoyslow/management/commands/cesiumcron.py", line 37, in get_sites_to_test
    return Site.objects.filter(userprofile__count>0).exclude(
NameError: global name 'userprofile__count' is not defined
(Assignee)

Comment 3

8 years ago
Also, the cron was setup incorrectly (the cesiumd-dist.cron has a minor fail, which I failed to notice) :

CESIUMPATH=/path/to/cesium/trunk/cesium/run_cesiumd.sh
*/15 * * * * $CESIUMPATH/run_cesiumd.sh

So it was trying to run /path/to/cesium/trunk/cesium/run_cesiumd.sh/run_cesiumd.sh

I've fixed that now. But the traceback is something you'd want to look at.
(Assignee)

Comment 4

8 years ago
Also, run_cesiumd.sh redirects to a logs/cronlog.txt file, or it'll complain (because of the redirect) and the redirect isn't useful since the traceback is stderr and is dumped on the screen :D That's another potential failure point (where the cron could have failed).
(Reporter)

Comment 5

8 years ago
Thanks Shyam, I'll try to reproduce the bug locally and see if I can fix it.
(Reporter)

Comment 6

8 years ago
r50293 should fix this problem. Let me know if it works.
(Assignee)

Comment 7

8 years ago
Ryan, you have access to the migrated VM, cm-cesium01.mozilla.org. I think you can poke around and ping me if you need further help :)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.